6

I have been using a Linux server via SSH for months, it still works from other locations but for some reason, this week, it isn't working from the office.

Putty says "Connection timed out"

Is there a way to determine where the problem is? Can i trace route on port 22 or something like that?

Just to clarify. I can SSH to my home Linux box, then SSH to the server. I just can't SSH to the server from work. I have contacted the host and I'm not blocked or blacklisted or anything like that.

6
  • Need more input. You want to connect from your Windows computer at work to your Linux server in the internet? Can it be that you are behind a corporate firewall? Commented Jan 7, 2014 at 6:41
  • Thanks for the reply, There is a firewall (smoothwall) which has outbound port 22 allowed. I can access my home SSH server but not our work server (hosted). If only i could put -trace on the SSH command so i could see where my connection is failing...that would be super dooper. Tested in the office on Windows8, Debian & MacOSX. Commented Jan 7, 2014 at 7:39
  • Have you seen the server side SSHD log file ? Paste here, if you can.
    – SHW
    Commented Jan 7, 2014 at 8:03
  • if you cannot connect to the server - can you ping it? Commented Jan 7, 2014 at 8:20
  • your internet box has been updated and suppress existing NAT ? your company put a firewall and restrict the use of port 22 ? that's just thoughts
    – Kiwy
    Commented Jan 7, 2014 at 8:54

1 Answer 1

8

You can use traceroute for this, with the options -T for TCP and -p 22 to specify the SSH port. When using these options, you need to run traceroute as root:

 sudo traceroute -p 22 -T sshserver.example.com
2
  • Thankyou, i didn't see the option for port in the traceroute docs. Commented Jan 8, 2014 at 5:20
  • Problem ended up being smoothwall, some clown had put a rule "enable SSH" which should have read "disable SSH". Commented Jan 8, 2014 at 5:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .