0

I am trying to emulate a raspberry pi on ubuntu. I have tried several ways using several tutorials but every time, the emulator logs this:

    scsi: 0:0:0:0 ABORT operation started
    scsi: 0:0:0:0 ABORT operation timed-out.
    scsi: 0:0:0:0 DEVICE RESET operation started
    scsi: 0:0:0:0 DEVICE RESET operation timed-out.
    scsi: 0:0:0:0 BUS RESET operation started
    scsi: 0:0:0:0 BUS RESET operation timed-out.
    scsi: 0:0:0:0 HOST RESET operation started
    sym0: SCSI BUS has been reset.
    scsi: 0:0:0:0 HOST RESET operation timed-out.
    scsi: 0:0:0:0 Device offlined - not ready after error recovery

This list is repeated over and over again.

1

Qemu 1.5 fixes the problem, which means you either compile it, or use this PPA at your own risk, as it includes many more things than qemu which you may not want to upgrade. Either way, one must be comfortable with command line and the apt system.

I found this solution when looking at the comments from Marvin in this post:

Ah, according to this it is an arm problem that has been fixed in QEMU 1.5… http://comments.gmane.org/gmane.linux.ports.arm.kernel/262493 Guess I’ll have to build it…

In my case I used the PPA route for installing Qemu 1.6, and got past this problem. However in the process of resolving this issue I also tried following the page hbdgaf pointed to in his comment. Once I reverted the changes made to /etc/ld.so.preload as explained by that page, qemu was finally able to mount the root filesystem and startup. But then other problems appeared such as a neverending login loop.

In the end, after many trial and error, I managed to succeed, and the most helpful document was this PDF which gives a few more tips.

YMMV...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.