Tried to use WebEx with the following setup:

Machine : intel i5 , x86 architecture OS : CentOs : 6.5 , Fedora 18 and Fedora 20 Java : jdk 1.7_45 64 bit Browser : firefox 26 with Java plugin enabled

With the above setup, able to schedule a meeting with WebEx. While meeting on the run, having issue with audio devices. Getting error message like "Audio Device Unaccessible Now" when I have clicked call using computer option.

While I am Googling the issue, I got a info like "Webex supports for 32 bit machines". But I don't believe in it.

Please guide me with the following : 1 ) If I have installed 32-bit Java the issue will be solved ? 2 ) Need to install any other stuff to enable WebEx in my machine ? ( Because, I have not installed anything related to webex) 3 ) May I run 32-bit and 64-bit Java for two different applications at same time ?

migrated from serverfault.com Jan 6 '14 at 5:05

This question came from our site for system and network administrators.

Please take a look at http://negativo17.org/enabling-cisco-webex-in-fedora-19-x86_64-and-i686 it solved my long time problem about not been able to see screenshares.

You basically need to run this as root (or using sudo):

$ sudo yum install icedtea-web pangox-compat.i686 libXmu.i686 \
      java-1.8.0-openjdk.i686 libgcj.i686 mesa-libEGL.i686

$ sudo setsebool -P \
      unconfined_mozilla_plugin_transition=off mmap_low_allowed=on

If on x86_64:

$ sudo yum install icedtea-web.x86_64 pangox-compat.x86_64 libXmu.x86_64 \
      java-1.8.0-openjdk.x86_64 libgcj.x86_64 mesa-libEGL.x86_64
  • It is better to provide the steps here, and use the link as a reference for further details. That way your answer does not loose all of it value when the link becomes invalid. – Anthon Jan 31 '14 at 20:22
  • @Manuel : I am using 64 bit machine. The article says, Webex program is compiled for 32 bit processor. What to do now. What to do now ? Do you have any other idea ? – ArunRaj Feb 1 '14 at 4:59
  • @user2959196 i'm running 64 bit too, you need to install the 32 bit dependencies, if you pay attention to the yum command in the article it makes reference to 32 bit dependencies. You need to install those. – Manuel Monge Feb 10 '14 at 23:32
  • @Manual Monge : I am having x86_b4 architecture. But the above packages supports i686 architecture. What to do now ? And also, I am having oracle java (1.6 update 41) instead of open jdk. – ArunRaj Feb 11 '14 at 4:43
  • @user2959196 - see updates for 64-bit. You should be able to use Oracle JDK instead of Iced Tea (OpenJDK). – slm Feb 13 '14 at 12:58

I had a similar messiness on a Linux Mint Rafaela 17.2 and solved it as follows. The steps are so generic, they might work on all kinds of Linuxes. If you have a yum based system, however, @manuel-monge's answer may be better suited.

Step 1: Download jdk-8u*-linux-i586.tar.gz, the 32bit version of Oracle's Java, choose just the plain .tar.gz and unpack into a directory of your liking.

Step 2: In firefox (version 55 in my case) go to Edit Preferences -> Applications and search for jnlp. Switch to "Always ask".

Step 3: Click on a Webex meeting link. It will now ask you what to do with a file of type jnlp. Save it to a place where you find it. In my case the file did not have the extension .jnlp, so I simply added it in the save-dialog (convenience, not really needed).

Step 4: invoke the javaws command found in the unpacked .tar.gz and pass it the jnlp file you just downloaded, i.e. something like this:

..../jdk1.8.0_144/bin/javaws CiscoWebExServlet.jnlp

You may need one or two more "ok, yes, ok ok!!!" clicks but then it worked for me.

Once this works, you may as well go back to Step 2 and instead of "Always ask" just enter the path to the javaws command from this 32bit Java.

see also: https://gist.github.com/mshkrebtan/407786e334847544b40e7d6a8a53d247

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.