How to get a Finepoint Digitizer Tablet to work under Fedora Core 16?

The hardware in question is a Gateway m285-E. It uses an active pen (has a battery in the pen).

    cat /dev/ttyS0 

returns input characters to the screen when the pen is close to the monitor. However, if I don't cat /dev/ttyS0 – say I'm just on the desktop, and press the pen to the screen, it crashes me back out to the Fedora login screen. How do I get this laptop to handle pen input properly?

Let me recap what we've tried so far:

Here's the modified contents of xorg.conf:

  Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    Screen      2  "Screen2" RightOf "Screen1"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Tablet"

  Section "InputDevice"
    Identifier "Tablet"
    Driver "fpit"
    Option "Device" "/dev/ttyS0"
    Option "AlwaysCore" "on"
    Option "InvertY"
    Option "MaximumXPosition" "12550"
    Option "MaximumYPosition" "7650"
    Option "MinimumXPosition" "400"
    Option "MinimumYPosition" "400"
    Option "SendCoreEvents"

Here's the contents of her /home/[user]/.xinitrc:

    xsetpointer TOUCHSCREEN
    xmodmap -e "pointer = 1 3 2"

Here's the contents of /etc/serial.conf

    /dev/ttyS0 uart 16550A port 0x06a8 irq 4 baud_base 38400 spd_normal skip_test

This configuration setting came from a user the same hardware who was having trouble on the Fedora forums. http://forums.fedoraforum.org/archive/index.php/t-270181.html

We've also tried serial.conf with these parameters, as described in the linuxquestions.org site. (http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/howto-get-your-gateway-or-finepoint-pen-working-497879/)

    /dev/ttyS0 port 0x03F8 irq 4 baud_base 38400 

There is a challenge with getting the fpit driver to run under Fedora. It's been cut out of the main branch, and on 19/20 you can no longer just yum install fpit. To get a functioning driver, we dove back into version 16. The ISO is here:


From there, we were able to download an RPM of fpit driver 1.4.0 for fedora from this URL.


I know it's a shot in the dark to ask about an older distro and a super-specific piece of hardware, but any insight would be MUCH appreciated!

  • 1
    You can always reach into the Koji build service and get the source RPMs and attempt to modify and rebuild them on Fedora 19/20. koji.fedoraproject.org/koji/buildinfo?buildID=259318
    – slm
    Jan 6, 2014 at 1:02
  • 1
    I would be tempted to take all the options out of the "InputDevice" section except for the 1st 3. Then reboot. Then fire up xev and confirm that the pen is sending events that X can see correctly. I would then add the options back in 1 at a time to see if you actually need them and if they're set values are right.
    – slm
    Jan 6, 2014 at 1:19


You must log in to answer this question.

Browse other questions tagged .