3

I'm trying to dial-up with my Huawei modem EM680 using wvdial. My modem is found properly on /dev/ttyUSB1 but when I execute wvdial I get this:

# wvdial
--> WvDial: Internet dialer version 1.61
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 +FCLASS=0
ATQ0 V1 E1 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","m2mstatic.apn"
AT+CGDCONT=1,"IP","m2mstatic.apn"
ERROR
--> Bad init string.
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 +FCLASS=0
ATQ0 V1 E1 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","m2mstatic.apn"
AT+CGDCONT=1,"IP","m2mstatic.apn"
ERROR
--> Bad init string.
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 +FCLASS=0
ATQ0 V1 E1 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","m2mstatic.apn"
AT+CGDCONT=1,"IP","m2mstatic.apn"
ERROR
--> Bad init string.
# 

Why does it say bad init string.? My /etc/wvdial.conf looks like this:

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 +FCLASS=0
Init3 = AT+CGDCONT=1,"IP","m2mstatic.apn"
Stupid Mode = yes
Modem Type = Analog Modem
ISDN = 0
New PPPD = yes
Phone = *99#
Modem = /dev/ttyUSB1
Username = ;
Password = ;
Baud = 9600
  • 1
    That error is because your modem rejected the Init3 string: --> Sending: AT+CGDCONT=1,"IP","m2mstatic.apn" AT+CGDCONT=1,"IP","m2mstatic.apn" ERROR That string came straight from the Init3 setting in your config file. Unfortunately, I have no experience with that hardware, or anything similar, so I can't really provide an answer... I can suggest help.ubuntu.com/community/DialupModemHowto/Huawei/E220 might help. – derobert Jan 4 '14 at 22:21
3

This wvdial.conf worked on ZTE 3G Modem below:

[Dialer Defaults] 
Modem = /dev/ttyUSB0 
Init1 = ATZ 
Init3 = AT+CGDCONT=1,"IP","apnname" 
Phone = *99***1#
Username = user
Password = user
New PPPD = yes 
Stupid Mode = 1

You can try it with my wvdial.conf.

1

I experienced the same problem, then found that I did not have a SIM card in the device. When I added the SIM card, it worked again.

Perhaps the SIM card is locked? I have seen other postings that have suggested adding:

AT+CPIN="0000"

to the script (https://help.ubuntu.com/community/DialupModemHowto/Huawei/E220)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.