1

I have been trying to get adb, fastboot, avd and others to work with the latest version of Linux Mint (16 "Petra")

I originally got this error when trying to run ADB:

➜  platform-tools  ./adb
./adb: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

After looking around I found suggestions saying that you need to install 32-bit compatibility libraries.

So, I tried to install the package ia32-libs, which, however, failed horribly.

➜  ~  sudo apt-get install ia32-libs                                   
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : 
         Depends: bluez-alsa:i386 but it is not going to be installed
         Depends: gstreamer0.10-plugins-base:i386 but it is not going to be installed
         Depends: gstreamer0.10-plugins-good:i386 but it is not going to be installed
         Depends: gtk2-engines:i386 but it is not going to be installed
         Depends: gtk2-engines-murrine:i386 but it is not going to be installed
         Depends: gtk2-engines-oxygen:i386 but it is not going to be installed
         Depends: gtk2-engines-pixbuf:i386 but it is not going to be installed
         Depends: gvfs:i386 but it is not going to be installed
         Depends: ibus-gtk:i386 but it is not going to be installed
         Depends: libacl1:i386 but it is not going to be installed
         Depends: libao4:i386 but it is not going to be installed
         Depends: libasound2:i386
         Depends: libasound2-plugins:i386 but it is not going to be installed
         Depends: libasyncns0:i386 but it is not going to be installed
         Depends: libattr1:i386 but it is not going to be installed
         Depends: libaudio2:i386 but it is not going to be installed
         Depends: libcanberra-gtk-module:i386 but it is not going to be installed
         Depends: libcap2:i386 but it is not going to be installed
         Depends: libcapi20-3:i386 but it is not going to be installed
         Depends: libcups2:i386 but it is not going to be installed
         Depends: libcupsimage2:i386 but it is not going to be installed
         Depends: libcurl3:i386 but it is not going to be installed
         Depends: libdbus-glib-1-2:i386 but it is not going to be installed
         Depends: libesd0:i386 but it is not going to be installed
         Depends: libfontconfig1:i386 but it is not going to be installed
         Depends: libfreetype6:i386 but it is not going to be installed
         Depends: libgail-common:i386 but it is not going to be installed
         Depends: libgconf-2-4:i386 but it is not going to be installed
         Depends: libgdbm3:i386 but it is not going to be installed
         Depends: libgettextpo0:i386 but it is not going to be installed
         Depends: libglapi-mesa:i386 but it is not going to be installed
         Depends: libglu1-mesa:i386 but it is not going to be installed
         Depends: libgphoto2-6:i386 but it is not going to be installed
         Depends: libgphoto2-port10:i386 but it is not going to be installed
         Depends: libgtk2.0-0:i386 but it is not going to be installed
         Depends: libmpg123-0:i386 but it is not going to be installed
         Depends: libncursesw5:i386 but it is not going to be installed
         Depends: libnspr4:i386 but it is not going to be installed
         Depends: libnss3:i386 but it is not going to be installed
         Depends: libodbc1:i386 but it is not going to be installed
         Depends: libopenal1:i386 but it is not going to be installed
         Depends: libpulse-mainloop-glib0:i386 but it is not going to be installed
         Depends: libpulsedsp:i386 but it is not going to be installed
         Depends: libqt4-dbus:i386 but it is not going to be installed
         Depends: libqt4-network:i386 but it is not going to be installed
         Depends: libqt4-opengl:i386 but it is not going to be installed
         Depends: libqt4-qt3support:i386 but it is not going to be installed
         Depends: libqt4-script:i386 but it is not going to be installed
         Depends: libqt4-scripttools:i386 but it is not going to be installed
         Depends: libqt4-sql:i386 but it is not going to be installed
         Depends: libqt4-svg:i386 but it is not going to be installed
         Depends: libqt4-test:i386 but it is not going to be installed
         Depends: libqt4-xml:i386 but it is not going to be installed
         Depends: libqt4-xmlpatterns:i386 but it is not going to be installed
         Depends: libqtcore4:i386 but it is not going to be installed
         Depends: libqtgui4:i386 but it is not going to be installed
         Depends: libqtwebkit4:i386 but it is not going to be installed
         Depends: librsvg2-common:i386 but it is not going to be installed
         Depends: libsane:i386 but it is not going to be installed
         Depends: libsdl-image1.2:i386 but it is not going to be installed
         Depends: libsdl-mixer1.2:i386 but it is not going to be installed
         Depends: libsdl-net1.2:i386 but it is not going to be installed
         Depends: libsdl-ttf2.0-0:i386 but it is not going to be installed
         Depends: libsdl1.2debian:i386 but it is not going to be installed
         Depends: libsqlite3-0:i386 but it is not going to be installed
         Depends: libssl0.9.8:i386 but it is not going to be installed
         Depends: libssl1.0.0:i386 but it is not going to be installed
         Depends: libstdc++5:i386 but it is not going to be installed
         Depends: libstdc++6:i386 but it is not going to be installed
         Depends: libxaw7:i386 but it is not going to be installed
         Depends: libxml2:i386 but it is not going to be installed
         Depends: libxp6:i386 but it is not going to be installed
         Depends: libxslt1.1:i386 but it is not going to be installed
         Depends: libxss1:i386 but it is not going to be installed
         Depends: libxtst6:i386 but it is not going to be installed
         Depends: odbcinst1debian2:i386 but it is not going to be installed
         Depends: xaw3dg:i386 but it is not going to be installed
         Depends: libgl1-mesa-dri:i386 but it is not going to be installed
         Depends: libgl1-mesa-glx:i386 but it is not going to be installed
         Depends: libpam-winbind:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any help would be very much appreciated.

EDIT: After following Rmano's suggestion to run this: sudo apt-get install libc6:i386 libgcc1:i386 gcc-4.6-base:i386 libstdc++5:i386 I got this error about unmet dependencies:

➜  ~  sudo apt-get install libc6:i386 libgcc1:i386 gcc-4.6-base:i386 libstdc++5:i386 libstdc++6:i386
[sudo] password for insanity: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgcc1 : Breaks: libgcc1:i386 (!= 1:4.8.1-10ubuntu9) but 1:4.8.1-10ubuntu8 is to be installed
libgcc1:i386 : Depends: gcc-4.8-base:i386 (= 4.8.1-10ubuntu8) but it is not going to be installed
            Breaks: libgcc1 (!= 1:4.8.1-10ubuntu8) but 1:4.8.1-10ubuntu9 is to be installed
libstdc++6:i386 : Depends: gcc-4.8-base:i386 (= 4.8.1-10ubuntu8) but it is  not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused  by held packages.

EDIT 2: It seems that I have to downgrade to an older version of a view core utils, however, I'm not sure that it is a safe idea.

0

I reinstalled Linux in the end. However, downgrading the packages worked fine.

|improve this answer|||||
0

I do not have a Mint installation so this is is just a guess. In newer Ubuntu (and derived) systems, ia32-libs is deprecated.

Maybe you can solve your problem by issuing

sudo apt-get install libc6:i386 libgcc1:i386 gcc-4.6-base:i386 libstdc++5:i386 libstdc++6:i386

as you can see suggested in https://askubuntu.com/questions/107230/what-happened-to-the-ia32-libs-package . More info in https://askubuntu.com/questions/359156/how-do-you-run-a-32-bit-program-on-a-64-bit-version-of-ubuntu.

|improve this answer|||||
  • It doesn't work. I get an error message about unmet dependencies. – severen Jan 3 '14 at 23:18
  • Really do not know... try to search the above links and to see if you have some held package (askubuntu.com/questions/363200/…). You can try apt-get install -f to see if it can fix the packages dependency mess... – Rmano Jan 3 '14 at 23:57
  • That didn't work either. >_> – severen Jan 4 '14 at 0:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.