6

I've just got a dedicated server which has 2x 1TB HDD. However, when I type df -h I get the following:

[root@sd-56537 ~]# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda2       916G  688G  182G  80% /
tmpfs           7.8G  368K  7.8G   1% /dev/shm
/dev/sda1       194M   61M  124M  34% /boot

How can I access the 2nd drive?

[root@sd-56537 ~]# fdisk -l

Disk /dev/sda: 999.7 GB, 999653638144 bytes
255 heads, 63 sectors/track, 121534 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000d74f9

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          26      204800   83  Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2              26      121404   974966784   83  Linux
/dev/sda3          121404      121534     1048576   82  Linux swap / Solaris
[root@sd-56537 ~]#

Here are some things that have been tried:

[root@sd-56537 ~]# udevadm trigger --verbose --dry-run | grep disk 
/sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/host0/target0:1:0/0:1:0:0/scsi_disk/0:1:0:0

 [root@sd-56537 ~]# ls -l /dev/disk/by-id; 
total 0 
lrwxrwxrwx 1 root root 9 Jan 2 13:38 scsi-3600508e00000000019b5485ed592d30e -> ../../sda 
lrwxrwxrwx 1 root root 10 Jan 2 13:38 scsi-3600508e00000000019b5485ed592d30e-part1 -> ../../sda1 
lrwxrwxrwx 1 root root 10 Jan 2 13:38 scsi-3600508e00000000019b5485ed592d30e-part2 -> ../../sda2 
lrwxrwxrwx 1 root root 10 Jan 2 13:38 scsi-3600508e00000000019b5485ed592d30e-part3 -> ../../sda3 
lrwxrwxrwx 1 root root 9 Jan 2 13:38 wwn-0x600508e00000000019b5485ed592d30e -> ../../sda 
lrwxrwxrwx 1 root root 10 Jan 2 13:38 wwn-0x600508e00000000019b5485ed592d30e-part1 -> ../../sda1 
lrwxrwxrwx 1 root root 10 Jan 2 13:38 wwn-0x600508e00000000019b5485ed592d30e-part2 -> ../../sda2 
lrwxrwxrwx 1 root root 10 Jan 2 13:38 wwn-0x600508e00000000019b5485ed592d30e-part3 -> ../../sda3

[root@sd-56537 ~]# lshw | grep -A 5 disk 
*-disk:0 UNCLAIMED 
description: ATA Disk 
product: TOSHIBA MG03ACA1 
vendor: Toshiba 
physical id: 0.0.0 
bus info: scsi@0:0.0.0 
-- 
*-disk:1 
description: SCSI Disk 
product: Virtual Disk 
vendor: Dell 
physical id: 1.0.0 
bus info: scsi@0:1.0.0 
-- 
*-disk:2 UNCLAIMED 
description: ATA Disk 
product: TOSHIBA MG03ACA1 
vendor: Toshiba 
physical id: 0.1.0 
bus info: scsi@0:0.1.0 
[root@sd-56537 ~]#

[root@sd-56537 ~]# blkid 
/dev/sda2: UUID="b93f6b9d-163e-4231-bac0-204ce290f0af" TYPE="ext4" 
/dev/sda1: UUID="858364a4-263a-4e78-9ec5-ed6b23471377" TYPE="ext4" 
/dev/sda3: UUID="6a4a69e0-6378-4c65-b7ba-e78e0b38013a" TYPE="swap" 
[root@sd-56537 ~]#
11
  • Please post the output of fdisk -l run as root.
    – terdon
    Commented Jan 3, 2014 at 14:01
  • added it to the original post
    – Exoon
    Commented Jan 3, 2014 at 14:02
  • You seem to have one drive of 1TB. What makes you think there is another one? Do you have physical access to the machine?
    – terdon
    Commented Jan 3, 2014 at 14:05
  • is /dev/sda2 not my 2nd drive? I bought a server from Online.net and it said 2x1TB HDD
    – Exoon
    Commented Jan 3, 2014 at 14:07
  • No, sdaX are all the same physical drive. A second drive would be sdbX. If you have physical access to the machine, open it and count the disks. Perhaps one is simply not connected. Alternatively, you might have this set up as a RAID, is that the case?
    – terdon
    Commented Jan 3, 2014 at 14:09

1 Answer 1

3

The lshw outputs lists the missing disk as UNCLAIMED:

a node is marked as UNCLAIMED if no specific support for it has been loaded (or lshw has been unable to identify the driver)

While the disk may be connected, it may not be connected properly or may be faulty and the disk driver was not able to recognize the disk. Running "dmesg | grep 0:0.1.0" after boot may reveal more details on that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .