Firstly, before I explain my problem, I have referred to the question previously asked on Ask.Fedora about the libGL error, which can be seen here.

I have been trying to play the game "FTL - Faster Than Light", and I have been running into problems where the graphics perform extraordinarily poorly, and the sound keeps turning into a strange buzzing sound. Upon looking further, I noticed that my Terminal outputted the following message during the game's launch.

libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.

After doing some further research, it would appear that this issue has affected multiple people on numerous distributions of Linux, all with different solutions. Below, I have provided as much information as I can to help diagnose my specific issue.

This also seems to be similar to Bug 971437 on the Red Hat bug tracker

When getting libGL debug info on glxinfo:

$ LIBGL_DEBUG=verbose glxinfo | grep direct
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib64/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib64/dri/swrast_dri.so
libGL: Can't open configuration file /home/jflory/.drirc: No such file or directory.
libGL: Can't open configuration file /home/jflory/.drirc: No such file or directory.
direct rendering: Yes

I have a feeling there is some sort of issue with my graphics card, because I am VERY new to Linux and I'm unsure about what I may need to properly be able to run games. Below, I have some of the numerous packages I have tried to install during this process.

$ cat /etc/ld.so.conf.d/nvidia-lib64.conf
cat: /etc/ld.so.conf.d/nvidia-lib64.conf: No such file or directory

$ cat /etc/ld.so.conf.d/nvidia-lib.conf
cat: /etc/ld.so.conf.d/nvidia-lib.conf: No such file or directory

$ sudo yum install mesa-libglapi
Loaded plugins: langpacks, refresh-packagekit
Package mesa-libglapi-9.2.5-1.20131220.fc20.x86_64 already installed and latest version
Nothing to do

$ sudo yum install xorg-x11-drv-nvidia-libs.i686
Loaded plugins: langpacks, refresh-packagekit
No package xorg-x11-drv-nvidia-libs.i686 available.
Error: Nothing to do

I have installed a few more things across the course of the night, but none of them seemed to have done any good, so I don't think they are relevant.

If any more information is needed, please let me know and I will provide. As a reminder, I am very new to Linux in general and I am still learning, so I am not the most familiar with all the different UNIX operations I am able to do.

Here's a quick rundown of my system specs:

$ uname -a
Linux localhost.localdomain 3.12.5-302.fc20.x86_64 #1 SMP Tue Dec 17 20:42:32 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

$ grep "model name" /proc/cpuinfo
model name      : Intel(R) Core(TM) i3-3120M CPU @ 2.50GHz

Edit #1

I ran sudo yum install mesa-dri-drivers and it appeared it is already installed on my system.

$ sudo yum install mesa-dri-drivers
Loaded plugins: langpacks, refresh-packagekit
Dropbox                                            |  951 B     00:00     
google-chrome                                      |  951 B     00:00     
updates/20/x86_64/metalink                         |  18 kB     00:00     
updates                                            | 4.6 kB     00:00     
updates/20/x86_64/primary_db                         | 3.0 MB   00:06     
updates/20/x86_64/updateinfo   FAILED                                          
ftp://mirror.nexicom.net/pub/fedora/linux/updates/20/x86_64/repodata/updateinfo.xml.gz: [Errno 14] curl#56 - "response reading failed"
Trying other mirror.
(1/2): updates/20/x86_64/updateinfo                  | 309 kB   00:01     
(2/2): updates/20/x86_64/pkgtags                     | 755 kB   00:23     
Package mesa-dri-drivers-9.2.5-1.20131220.fc20.x86_64 already installed and latest version
Nothing to do

Edit #2

After executing lspci -vvv -s 00:02.0, my output was the following:

# lspci -vvv -s 00:02.0
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
    Subsystem: Toshiba America Info Systems Device fa20
    Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Interrupt: pin A routed to IRQ 16
    Region 0: Memory at c8000000 (64-bit, non-prefetchable) [size=4M]
    Region 2: Memory at c0000000 (64-bit, prefetchable) [size=128M]
    Region 4: I/O ports at 4000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
        Address: 00000000  Data: 0000
    Capabilities: [d0] Power Management version 2
        Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
        Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [a4] PCI Advanced Features
        AFCap: TP+ FLR+
        AFCtrl: FLR-
        AFStatus: TP-
  • Are you sure that swrast is even worth your time? Sounds like the performance from it will not be what you want. steamcommunity.com/app/221410/discussions/2/828934089701456106. I think you should look into making sure that you're using the hardware vendor's actual drivers for your setup and nothing but.
    – slm
    Commented Jan 2, 2014 at 16:57
  • @slm Whatever it is, it is making gaming on my laptop near impossible. I can presume it may be something with the drivers for my hardware, but I've been messing with this all day and I seem to be getting nowhere. After running lspci in the terminal, the output was 00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09). I've also been looking at these Intel Linux graphics drivers, but I'm having an even harder time with them.
    – J.W.F.
    Commented Jan 3, 2014 at 5:44
  • Can you get the output from lspci -vvv -s 00:02.0? Post it on the Q if you can.
    – slm
    Commented Jan 3, 2014 at 5:51
  • @slm Just added it now.
    – J.W.F.
    Commented Jan 3, 2014 at 5:59
  • I think these are your drivers listing.driveragent.com/c/pci/8086/0116/1179fa20
    – slm
    Commented Jan 3, 2014 at 6:17

1 Answer 1


Original answer provided on Ask Fedora (source)

Original comment

Also, please try adding i915.modeset=1 to kernel command line when booting (you should edit Fedora line in grub and add it to the end of linux/linux16/linuxefi line in the boot config, and then press F10), and then run glxinfo when booted.

Also, I'd like to know what do you see when you boot Fedora? The Fedora logo which is being filled with white color, or 3 simple bars at the bottom of screen?


As can be seen in your last glxinfo output after adding i915.modeset=1 to kernel boot command line, your graphics driver has been loaded and is working successfully. Previously, it did not load at all and you were using a generic driver.

However, this is actually a bug. Kernel should have been loading i915 driver automatically. Please report a bug about this issue with sufficient data at: https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora If you don't, I can do it myself but they might need some data that I cannot provide. Thanks!

Update 2

To change kernel command line permanently, you can:

  1. If you don't want to run grun2-mkconfig to generate new configuration file, you should edit /boot/grub2/grub.cfg and add the command line option (the format is exactly like what you see when you edit boot entry on boot) to the Fedora menu entry items.
  2. Even if you go with the above solution, you might some day run grub2-mkconfig -o /boot/grub2/grub.cfg to create a new configuration file (which will completely overwrite /boot/grub2/grub.cfg so your changes to it will be lost). Therefore, I'd suggest to also edit /etc/default/grub and add i915.modeset=1 at the end of GRUB_CMDLINE_LINUX= line (but before the closing "); so that it'll become something like this:

GRUB_CMDLINE_LINUX="vconsole.font=latarcyrheb-sun16 $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rhgb quiet i915.modeset=1"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .