10

I'm trying to turn on scrolling and tapping with my laptop's touch-pad (the 2 left and right buttons are ok). I'm on Debian 7.3 (Wheezy) KDE-desktop and I have a Synaptic touch-pad. My laptop is an old HP model of 2007 therefore it doesn't support multi-touching. As root I created a /etc/X11/xorg.conf.d/synaptics.conf file which I have copied below. Then in Konsole I gave synclient -l and got back the following code:

Parameter settings:
LeftEdge                = 1752
RightEdge               = 5192
TopEdge                 = 1620
BottomEdge              = 4236
FingerLow               = 25
FingerHigh              = 30
FingerPress             = 256
MaxTapTime              = 180
MaxTapMove              = 221
MaxDoubleTapTime        = 180
SingleTapTimeout        = 180
ClickTime               = 100
FastTaps                = 0
EmulateMidButtonTime    = 75
EmulateTwoFingerMinZ    = 282
EmulateTwoFingerMinW    = 7
VertScrollDelta         = 100
HorizScrollDelta        = 100
VertEdgeScroll          = 0
HorizEdgeScroll         = 0
CornerCoasting          = 0
VertTwoFingerScroll     = 1
HorizTwoFingerScroll    = 0
MinSpeed                = 1
MaxSpeed                = 1.75
AccelFactor             = 0.0398
TrackstickSpeed         = 40
EdgeMotionMinZ          = 30
EdgeMotionMaxZ          = 160
EdgeMotionMinSpeed      = 1
EdgeMotionMaxSpeed      = 401
EdgeMotionUseAlways     = 0
TouchpadOff             = 0
LockedDrags             = 1
LockedDragTimeout       = 5000
RTCornerButton          = 0
RBCornerButton          = 0
LTCornerButton          = 0
LBCornerButton          = 0
TapButton1              = 0
TapButton2              = 0
TapButton3              = 0
ClickFinger1            = 1
ClickFinger2            = 1
ClickFinger3            = 1
CircularScrolling       = 0
CircScrollDelta         = 0.100007
CircScrollTrigger       = 0
CircularPad             = 0
PalmDetect              = 0
PalmMinWidth            = 10
PalmMinZ                = 200
CoastingSpeed           = 20
CoastingFriction        = 50
PressureMotionMinZ      = 30
PressureMotionMaxZ      = 160
PressureMotionMinFactor = 1
PressureMotionMaxFactor = 1
GrabEventDevice         = 1
TapAndDragGesture       = 1
AreaLeftEdge            = 0
AreaRightEdge           = 0
AreaTopEdge             = 0
AreaBottomEdge          = 0
HorizHysteresis         = 25
VertHysteresis          = 25
ClickPad                = 0

This is the content of /etc/X11/xorg.conf.d/synaptics.conf

Section "InputClass"
Identifier "Touchpad"
MatchIsTouchpad "yes"
Driver "synaptics"
Option "MinSpeed" "0.4"
Option "MaxSpeed" "0.9"
Option "AccelFactor" "0"
Option "TapButton1" "1"
Option "TapButton2" "3"
Option "VertTwoFingerScroll" "0"
Option "HorizTwoFingerScroll" "0"
Option "VertEdgeScroll" "1"
Option "CoastingSpeed" "8"
Option "CornerCoasting" "1"
Option "TouchpadOff " "0"
EndSection

I've installed apt-get install server-xorg-input-synaptics and rebooted the system after the creation of the synaptics.conf file but nothing has changed.

What should I do to get it working?

  • I tried what terdon said and it initially worked but after restarting the system all the changes had disappeared. I then tried synapticks from the K start menu > Applications > Utilities (I had installed it previously, but couldn't see it in the system tray). I read carefully each instruction and configured it properly this time. Then I restarted the system and the tapping and scrolling were still working! – WobblyWindows Jan 2 '14 at 18:29
  • Kali Linux 2.0 with i3 Desktop. Also for me "synclient TapButton1=1" solved issue. – user164577 Apr 6 '16 at 17:19
  • To have hardware details here would be helpful, etc about the manufacturer of your touchpad. – Léo Léopold Hertz 준영 Oct 9 '17 at 21:21
7

Have you tried synaptiks? It's a simple GUI program that always solved any problems with my touchpad configuration.

To install:

sudo apt-get install kde-config-touchpad

Then you should be able to run it with

synaptiks && synaptiks

(the first synaptiks only puts the icon in the system tray and doesn't launch the GUI for some reason)

10

EDIT: I just got tapping working on my Debian AlpsPS/2 touichpad with synclient:

synclient TapButton1=1

I am not an expert on this but found an old synaptics.conf file that I was using on a different laptop:

Section "InputClass"
    Identifier      "touchpad catchall"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Option          "HorizEdgeScroll"    "1"
    Option          "MaxTapTime"        "300"
    Driver          "synaptics"
EndSection

So, try adding catchall to the Identifier and changing MatchIsTouchpad to on from yes. Not sure if that will help but should be worth a try.

Another thing you can try is installing tpconfig:

sudo apt-get install tpconfig 

That should give you a GUI to enable taps with:

 sudo tpconfig --tapmode=1

Though I just tried this on my system and it does not seem to work

  • @WobbyWindows should be synclient HorizEdgeScroll=1. – terdon Jan 2 '14 at 17:07
  • Sorry for the stupid question I posted earlier: synclient TapButton1=1 and synclient VertEdgeScroll=1 did the job! You saved my day. Many many thanks. – WobblyWindows Jan 2 '14 at 17:07
  • @WobbyWindows yes, sorry, I meant VertEdgeScroll=1. – terdon Jan 2 '14 at 17:09
  • 1
    Simply add Option "TapButton1" "1" to your /etc/X11/xorg.conf or other file from /etc/X11/xorg.conf.d to make your changes permanent. My tests showed that to enable tapping on the touchpad, you should provide at least the following: Option "TapButton1" "1", Identifier "Touchpad", MatchIsTouchpad "yes" and Driver "synaptics" in Section "InputClass" (...) EndSection. – patryk.beza Jul 6 '16 at 21:55
  • 1
    @patryk.beza you might want to post an actual answer. That's the third version of that comment I've gotten a notification for :P – terdon Jul 6 '16 at 21:59
1

In KDE there is a new program that has superceded synaptiks: kcm-touchpad

This program will enable a new option in the System Settings. To access this options open System Settings (systemsettings in console), and go to Input Devices -> Touchpad

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.