I'm using RHEL 6 . I'm unable to play the video using Movie Player. It shows an error, Movie Player requires additional plugins to decode this file. The following plugins are required : MPEG-4-AAC decoder and H.264 decoder. But RHEL asking for a subscription. How to solve this problem or Suggest me any alternate softwares to install ?

  • 3
    Red Hat is a subscription-based, paid enterprise distribution. if you don't like it, get CentOS. – strugee Jan 2 '14 at 7:13
  • I'd second strugee's advice, given this issue plus your earlier Q about LibreOffice, you should probably be looking to CentOS instead of RHEL. – slm Jan 2 '14 at 7:14
  • yes, I need CentOS @slm – Sabapathy Jan 2 '14 at 10:58
  • Consider using mplayer, available at www.mplayerhq.hu. It comes with most codecs as part of its installation. There's even pre-built RPMs for RHEL in the "download" section. – dg99 Jan 2 '14 at 18:40

I solved the problem by installing the RPM Fusion repo and then yum install gstreamer-ffmpeg


Install oneplay-gstreamer-codecs-pack will solve this.


I installed gstreamer* and vlc, and ensured that VLC would read the mpeg files

  • 3
    Hi Leslie Satenstein. How did you do that? What made you choose those particular pieces of software? You should edit your answer to provide more details; otherwise, it may be at risk of being deleted as low quality. Answers that give the why and the how are much more useful not only to the person originally asking the question (in this case two and a half years ago) but also to people who might come across this question in the years to come. See How do I write a good answer? in our site's help center for some further hints. – user Jun 27 '16 at 16:54

I got the MPEG-1 video decoder plugin error and it resolved with following:

External repository created through below packages and installed required plugins.

  1. epel-release-6-5.noarch.rpm
  2. rpmfusion-free-release-6.noarch.rpm

Then through Yum installed gstreamer-ffmpeg.x86_64 0:0.10.11-2.el6 package and its dependency.

  gstreamer-ffmpeg.x86_64 0:0.10.11-2.el6

Dependency Installed:
  dirac-libs.x86_64 0:1.0.2-4.el6
  ffmpeg-compat.x86_64 0:0.6.7-1.el6
  lame-libs.x86_64 0:3.99.5-1.el6
  librtmp.x86_64 0:2.3-3.el6
  libva.x86_64 0:1.0.15-1.el6
  orc.x86_64 0:0.4.16-6.el6
  schroedinger.x86_64 0:1.0.8-4.el6
  x264-libs.x86_64 0:0.120-5.20120303.el6
  xvidcore.x86_64 0:1.3.2-3.el6
yum install oneplay-gstreamer-codecs-pack 

did it for me.


The packages that worked for me, using REDHAT 7.4 enterprise, were the following:

*** nux-dextop-release-0-5.el7.nux.noarch.rpm *** 

If you don't find exact, you can always find alternatives, at http://www.pkgs.org, just get ur version right i386, i586 or x86_64.

with RH 7.4 u can also use centOS, Fedora & RH & noarch.

  • 1
    How would you be able to use centOS packages, for example? Can it cause any problems mixing and matching? – Guy Jan 30 '18 at 0:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.