I created a somewhat similiar question previously, but seeing as my understanding of the topic improved drastically with the answers, I realized that I had asked the wrong question.

I am trying to create a Windows 7 USB on my 8 GB stick. I am using Fedora 19 and so far:

  • UNetbootin. While this seemingly works (only if the stick is formatted to a somewhat old laptop (Dell Latitude D630). I have tried the following methods FAT32), trying to boot the stick only gives me the alternative "default" with a countdown. Its the same error described other places, such as here. I have not succeeded in finding a good alternative to try, as someone claims that formatting to NTFS would do the trick, but UNetbootin won't recognize the stick in NTFS.
  • "dd". While it claims to copy 4.1 GB, and the name of the stick is automatically changed to "WINDOWS7", the "Discs"-GUI provided in Fedora claims that only 0.5GB is used, and attempting to boot leaves me with "Unable to find operating system" or "Missing operating system", something along those lines. It also looks like it changes the format to UDF.
  • WinUSB. Returns error 32512.

Are there any alternative methods? Or improvements/changes upon methods I have already tried?

EDIT: I found a method that many have claimed to work:

  1. make one partition, format as NTFS & mark bootable
  2. write boot sector (ms-sys -7)
  3. mount and copy all the files from the iso

How do I do steps 2 and 3?

  • 1
    Concerning dd, I already faced such problem, changing the value for the bs parameter fixed it. The Fedora Project website suggests 8M. More info : fedoraproject.org/wiki/How_to_create_and_use_Live_USB Commented Jan 1, 2014 at 14:37
  • Thank you. I am currently attempting this, and will edit with results as soon as I am done. (Did you use 8M when you did it?) Commented Jan 1, 2014 at 14:42
  • I am no Fedora User, I met the problem when manipulating Arch ARM images. I needed 1M. Commented Jan 1, 2014 at 14:52
  • I simply got the error "No boot (something) on USB device." I will try again, seeing as the USB acted a bit weird during the process (possible disconnect.) Commented Jan 1, 2014 at 14:57
  • You may want to wipe it clean before dd-ing. See about formatting, and partitionning. Commented Jan 1, 2014 at 14:59

1 Answer 1


Did you try to install grub2 or grub 0.9X onto your USB drive? It always work for me. (SSK/Kingston USB stick + Thinkpad laptop, the USB key is booted in HDD mode)

After installation you will also need to convert isolinux configuration to grub compatible configuration, which is quiet easy to do.

The isolinux configuration file is usually called text.cfg or menu.cfg, under the isolinux folder of the iso image. (Just read all of them to find out, I don't have a Fedora image at hand)

Then you can copy all of the rest onto your stick, squashfs, kernel and initrd etc.

  • 1
    I am unfamiliar with many of the terms here, but I will Google around and see what I can make of it. If you feel like it I'd highly appreciate it if you made your answer (even more) noobfriendly :) Commented Jan 1, 2014 at 15:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .