1

I need to transcribe some audio files. The original format is .WMA. I've tried using both:

ffmpeg -i some.WMA some.wav

and

pacpl -to wav some.WMA some.wav 

as well as exporting with Audacity to mp3.

I've updated to the newest ffmpeg. The problem (despite the error message) doesn't seem to be the conversion.

Namely,

file some.wav 

shows

some.wav: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit, stereo 44100 Hz

and I still get the same resulting error message when trying to play some.wav (.mp3) with playitslowly:

** (app.py:31502): WARNING **: cannot set NULL uri
** Message: don't know how to handle audio/x-wma, wmaversion=(int)2, bitrate=(int)128016, depth=(int)16, rate=(int)44100, channels=(int)2, block_align=(int)5945, codec_data=(buffer)009000000f0039170000

(How) can I remedy this?

1

Rather than monkey around with your distro's version of ffmpeg I'd suggest just getting the statically built version available on the FFmpeg's project page.

They offer many pre-built versions for different architectures. Once you download and unpack it you can run it like so:

$ ./ffmpeg -i some.WMA some.wav
  • I updated to the newest ffmpeg. The problem doesn't seem to be the actual conversion. [I added comments above.] It seems to be some mystery with playitslowly. (Which I used in the past with no issues.) – Donnied Jan 1 '14 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.