2

I am not able to install Linux in my newly built machine. I think it can be related with my MB (Asrock Z87 Extreme6). I already have Windows 8.1 installed without UEFI.

When I boot (linux) from the BluRay Drive, if I use legacy boot it won't boot at all. If I choose to use UEFI, sometimes it boots, but it fails to install.

I have tried several distros (Ubuntu, Debian, Slackware), but with no success. Any idea what's the problem?

I have even tried OpenBSD, but no luck there as well.

Machine configuration:

  • Kingston HyperX blu Memory 16GB
  • Seagate 1TB SATA600
  • Asrock Z87 Extreme6
  • Intel Core i5 4570, 3.2GHz
  • Asus BW 16D1HT
  • Using onboard GPU
  • 2
    It would be much easier to help you if you would post any details like error messages that you see or if you describe what's happening when it fails. – replay Dec 31 '13 at 14:14
  • 1
    What Mauro said. Also, are you 100% sure it is not a UEFI setup? Can you boot a live session CD? I see no reason why your MB would cause problems. – terdon Dec 31 '13 at 14:20
  • Sorry, at work now. Not able to post the concrete errors. Will do it later. Windows 8.1 is not in UEFI 100%. Was not able to boot from a live CD. – Rui Lima Dec 31 '13 at 14:23
  • When I try to boot without UEFI I get "Machine check error" in big letters. Updated the UEFI, booted with UEFI, I was able to load the installation menu until the partitions menu, I don't have the time now to go forward with this. I have to take a new try later. I will keep you updated. – Rui Lima Dec 31 '13 at 20:29
  • I would need to reinstall windows, because is not UEFI. Does anyone knows why I get the "Machine check error" when using a non UEFI boot? – Rui Lima Jan 1 '14 at 13:55
1

Short: don't use DVI-D, use HDMI >:(

Well guys, gave it a try again. And finally did it! :D

Just installed Linux Mint debian based version. This time the only problem I found was the display, when I had it connected to my onboard card using the DVI-D nothing was shown, had to connect it using a HDMI cable. :( I would really like to have it connected in the DVI-D port, need to HDMI to connect other devices.

I was getting tired of running Debian in a virtual machine. But this cable thing is really a big downside. :( Well, when I get more time I'll try to fix it.

I am also starting to wonder if previously the live distros were starting but I didn't noticed because I got no picture. Today I found that the system has booted because I've been working on Windows and left the speakers ON, so I heard the starting sound of the Linux Mint... maybe it was always working... :(

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.