I've booted from SLES 10 SP2 CD and installed Gentoo. Now I'm trying to make Ethernet work (it is working in SLES). I found this document, but in current kernel ( sysfs layout is some different, for example, there is no parameters file in qeth device directory, but it have separate file portname.

After echo 0.0.0100,0.0.0101,0.0.0102 > /sys/bus/ccwgroup/drivers/qeth/group sysfs contains new directory /sys/devices/qeth/0.0.0100 with few files and directories inside. File portname contains "no portname required". But when I'm trying to write 1 to file online it says:

-bash: echo: write error: No such device

I also tried to write "OSAPORT" to portname, 0 and 1 to layer2 with no success. I still can not create eth0 interface.

What am I missing and how to corretly make eth0 configured at boot time in Gentoo?

  • Are there any network devices showing up in ifconfig -a besides lo? Also, can you figure out which kernel modules are loaded for Ethernet under SLES with lsmod? – penguin359 Apr 6 '11 at 11:09
  • ifconfig -a shows lo and sit0. IIRC, SLES loads qdio and qeth modules, and I have both compiled-in on Gentoo. – gelraen Apr 6 '11 at 17:24
  • I usually recommend using modules for non-critical devices as it's usually easier to debug and test. For example, if you need to change a modules parameters, however, it appears that none of the s390 network drivers use module parameters. I'd be curious to see what find /sys -name '*eth*' and dmesg | grep -E '(qdio|qeth)' reveals under both Gentoo and SLES. – penguin359 Apr 6 '11 at 17:50
  • Have you tried booting from a Gentoo live cd? If so, did you execute net-setup? – Tok Apr 7 '11 at 19:07
  • 1
    I think you have more luck using the gentoo email lists. S390 is not very common and it seems your problem is specific to it. – Paul de Vrieze May 27 '11 at 15:45

From my experience, "-bash: echo: write error: No such device" usually means there is no kernel support for a given device. So you should try to reconfigure and rebuild your kernel. If you can find any other working kernel (e.g. from SLES), its config will be the best starting point.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.