6

I just upgraded to Cinnamon 2.0.14 on my LMDE laptop and in this new version I am unable to change the GTK engine used. Menus and widgets in general look very ugly:

enter image description here

When they should look something like this:

enter image description here

In principle, I should be able to change this using Cinnamon's own settings app in System Settings => Themes => Other Settings => Controls:

enter image description here

However, while most options available in that window work (Window Borders for example), the "Controls" and "Icons" options are ignored.

Starting from version 2.0, Cinnamon has become independent of Gnome and in fact conflicts with it. I have therefore had to remove Gnome to install this version of Cinnamon which may be relevant. I do have the necessary GTK packages installed though:

$ dpkg -l | grep engines | grep gtk | awk '{printf "%s  %-26s %-22s\n",$1,$2,$3}'
ii  gtk2-engines:amd64         1:2.20.2-3            
ii  gtk2-engines-aurora        1.5.1-3               
ii  gtk2-engines-candido       0.9.1-pablo4          
ii  gtk2-engines-magicchicken  1.1.1-9               
ii  gtk2-engines-moblin        1.1.1-1.1             
ii  gtk2-engines-murrine:amd64 0.98.1.1-5            
ii  gtk2-engines-nodoka        0.7.0-1.2             
ii  gtk2-engines-oxygen:amd64  1.3.3-2               
ii  gtk2-engines-pixbuf:amd64  2.24.20-1             
ii  gtk2-engines-wonderland    1.0-8                 
ii  gtk2-engines-xfce          3.0.1-2               
ii  gtk3-engines-oxygen:amd64  1.1.4-1               
ii  gtk3-engines-unico:amd64   1.0.2-1        

So, how can I choose the GTK engine used by Cinnamon to make my new desktop pretty?

3

how can I choose the GTK engine used by Cinnamon to make my new desktop pretty?

WRT GTK 2: Try installing gtk-chtheme. This is an independent application:

gtk-chtheme screenshot

I don't use Cinnamon (or Mint) but this has never failed to override a DE's settings for me.

These settings are (I presume) universally kept in ~/.gtkrc-2.0, but being able to browse the themes graphically makes things a little simpler.

  • Ah, great tool, thanks and +1. That seems to work for some programs (firefox for example) but not for others (like nemo, the file manager). I am guessing this might be a GTK2 vs GTK3 issue. I know that nemo uses GTK3, any way of changing the GTK3 engine? – terdon Dec 30 '13 at 12:25
  • I don't know of anything that parallels this, but I think the parallel config file is probably ~/.config/gtk-3.0/settings.ini -- you could try editing that and restarting Cinnamon. :\ – goldilocks Dec 30 '13 at 12:32
  • 1
    Yeah, I just found that out and am trying to tweak it now. There's some useful info (as always) on the arch wiki page on GTK+. – terdon Dec 30 '13 at 12:33
3

Most of these issues came because I was using a private repository linked to sid as described here. Turns out I had only upgraded part of cinnamon and its dependencies and my problems were fixed by pointing my sources.list to the Debian sid repos and running

sudo apt-get install gtk3-engines-*

I can now change the appearance of my desktop as required. In the process, I came across a nifty little program called lxappearance that is similar to gtk-chtheme but gives more options. I highly recommend it, it is in the Debian repos and can be installed with

sudo apt-get install lxappearance 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.