I tried to get MTPFS working on a Scientific Linux 6.4 desktop because of a phone

[root@notebook mtpfs-read-only]# sh autogen.sh 
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking whether gcc and cc understand -c and -o together... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for FUSE... yes
checking for MTP... configure: error: Package requirements (libmtp >= 1.1.0) were not met:

Requested 'libmtp >= 1.1.0' but version of libmtp is 1.0.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables MTP_CFLAGS
and MTP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

[root@notebook mtpfs-read-only]# cd
[root@notebook ~]# ls
libmtp-1.1.0-1.fc16.x86_64.rpm  mtpfs-read-only  rts
[root@notebook ~]# rpm -i libmtp-1.1.0-1.fc16.x86_64.rpm 
warning: libmtp-1.1.0-1.fc16.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID a82ba4b7: NOKEY
error: Failed dependencies:
    libc.so.6(GLIBC_2.14)(64bit) is needed by libmtp-1.1.0-1.fc16.x86_64
[root@notebook ~]# 

I don't have enough courage to upgrade libc.so.6. So, how to proceed?


you don't need to upgrade libc6.so; you can instead compile your own libmtp-1.1.0 with the current glibc, with some luck it won't actually need glibc 2.14 features.

Alternatively you could give go-mtpfs a try, it's quite a bit better than fuse-mtpfs, if you installed golang. At least I successfully transferred a couple of files to my phone with go-mtpfs, while I never, ever successfully transferred anything with fuse-mtpfs.

In any case, be prepared to lots of pain and frustration: mtp only barely works on anything I tried it with (Ubuntu, slackware, OS X). Failed transfers, disconnections, anger and pain, rebooting the PC and the phone repeatedly... Mtp is probably a deliberate attempt to hurt everyone not using MS windows and will make you bitterly regret the simple times of USB storage mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.