0

My Ubuntu 13.10 installation does not hibernate, no matter what I do. Although I have Tuxonice and enough swap space to cover the real RAM, it still doesn't work.

Is the problem specific to Ubuntu or to the machine? If it's the former, I'd try to install a different Linux dist, otherwise I'd give up.

Update: VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18) (prog-if 00 [VGA controller])

I have 50% of free RAM.

There is no problem suspending the machine.

I have tried all the tips on https://www.kernel.org/doc/Documentation/power/basic-pm-debugging.txt.

  • Note you also need enough free RAM to create the image, I've added a few paragraphs to my answer about this. – goldilocks Dec 29 '13 at 14:07
  • Please give us some info on your hardware, including your graphics card. – terdon Dec 29 '13 at 14:09
4

Try putting this in a script:

#!/bin/bash

sync
echo shutdown > /sys/power/disk
echo disk > /sys/power/state

and run it as root (su root, for which you need a root password, you may also be able to use sudo -i with your own password). I've noticed with, e.g., KDE, that the various shutdown options do not all work for me as an unprivileged user.

If that doesn't work there is probably something wrong with the kernel ACPI module(s) in relation to your hardware.

Note, however, that you also need enough RAM to create the hibernation image, not just swap. Otherwise, you will fail with a "not enough free memory" error. If that happens, try adding:

echo 0 > /sys/power/image_size

To the top of that script. To see the current image size, use cat /sys/power/image_size. This is the maximum size of the image, but if set to zero, it will be as small as possible (presumably the kernel opts to minimalize compression, so it prefers larger images if allowed).

To check what suspend states are available on your hardware:

cat /sys/power/state

You should see a short list including at least standby mem disk. Documentation for this stuff is in [kernel src]/Documentation/ABI/testing/sysfs-power.

  • The script outputs the error "echo: write error: Device or resource busy" with or without the last line. – Quora Feans Dec 29 '13 at 16:39
  • 1
    Try running each command individually to see which one fails. Also have a look at cat /sys/power/state (I've added a few more paragraphs about that). – goldilocks Dec 29 '13 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.