8

So, I have a server that I have RDC (Remote Desktop Connection) set up on, and I am looking at making it globally available on the internet so that I can access it from anywhere. I am currently in the process of changing the password so that it's more secure now that it's going to be visible on the web, but I'm running into a bit of a snag.

I'll use some example passwords here.

  • Before I changed my password, I had full access using RDC and my previous password: abc123.

  • I used passwd to change my password from abc123 to d4f5g6. The change was successful, but is only fully recognized when I type it at the machine itself, but not from RDC

When I try to connect using RDC and use my new password, I get the following error:

connecting to sesman ip 127.0.0.1 port 3350
sesman connect ok
sending login info to sesman
xrdp_mm_process_login_response: login successful for display
started connecting
connecting to 127.0.0.5910
tcp connected
security level is 2 (1 = none, 2 = standard)
password failed
error - problem connecting

Note that the password is currently d4f5g6, and I only get this error when I use d4f5g6. If I use any other password including abc123, I get this error:

connecting to sesman ip 127.0.0.1 port 3350
sesman connect ok
sending login info to sesman
xrdp_mm_process_login_response: login failed

Also note that I am typing these credentials within the connection, and they are not cached within RDC, so RDC doesn't seem to be playing into this at all.

So, it seems my correct password is getting through a first check just fine, but not through a second check? Here's the kicker; If I change my password back to abc123 directly on my server, then I can successfully connect to the server with RDC using abc123...

3
  • Have you restarted the RDC server after the password change?
    – Zelda
    Dec 29, 2013 at 7:06
  • I have restarted the RDC program, but not the actual server yet, no. I must try it in the morning though, and it will be silly if that's all there is to it. Dec 29, 2013 at 7:09
  • "connecting to 127.0.0.5910" is this right? or a typo within the IP?
    – user195730
    Oct 18, 2016 at 13:13

5 Answers 5

10

I had a user with the same problem and after trying Sjaak's solution he still couldn't log in so on a whim I did a ps -ef|grep vnc and found a process with the users UID so I killed that process and had the user try again and login was successful.

3
  • 2
    Thx, Akers Your answer saved my ass Dec 2, 2014 at 17:29
  • Awesome, this is also useful when U want to kick the f off the GUI to let the server breathe. Dec 22, 2014 at 19:42
  • 3
    Did also solved my problem, but what can I do so those old processes is closed by itself? Mar 13, 2015 at 11:27
3

On the Ubuntu server you can delete the (contents of) the .vnc hidden folder in your home directory. That caches your old password. It will be recreated the next time you login and will then use your new password.

1
  • Just to expand on Sjaak Dalens answer, this confusing error comes also when your .vnc dir is on an nfs and it becomes stale (nfs stale file handle)! Of course the solution is to remount it.
    – Jay Random
    Sep 25, 2017 at 0:38
1

I solved this by connecting via ssh to the RDC and entering these commands:

  1. ps -ef|grep vnc
  2. On first column of results, find the username that cannot login.
  3. Look at the process_ID next to the username that cannot login.
  4. sudo kill process_ID
  5. Reconnect to the RDC.
1

Add this in sesman.ini under [Xvnc] solved my problem!

param8=-SecurityTypes
param9=None 

$sudo nano /etc/xrdp/sesman.ini

Find the "param" I added

param8=-SecurityTypes
param9=None

Then run:

$sudo service xrdp restart

After I was able to log in and connect successfully.

1
  • cheers mate, this solution saved my two hours of trying the answers above. XD Jan 10, 2019 at 19:48
0

I ran into the same error message. Problem turned out to be the username. I was trying to log in as "HomeServer". It only works if I log in as "homeserver".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.