0

I'm seeing a strange problem when completing folders with zsh 5.0.2 (and oh-my-zsh). When I go to tab complete folder names for a relative path, the folder names often duplicate and lose colour highlighting. It's frustrating as I then have to tab complete through each directory twice to get to the one I want.

It only happens if what I'm completing from finishes with a "/" so for example, "dev/" or "dev/code/" would cause the problem, but "dev/c" would not. Also the problem doesn't seem to happen for absolute paths "/home/dave/dev/" is fine.

I've attached an animation showing the problem below:

Duplicating completion

I don't have anything particularly fancy in my zsh config (which is here: https://github.com/actionshrimp/dotfiles/blob/master/zshrc)

Any ideas what could be causing this?

migrated from stackoverflow.com Dec 29 '13 at 3:47

This question came from our site for professional and enthusiast programmers.

  • 1
    purging oh-my-zsh would be a good first step. removing each of those 'plugins' one by one and see if it goes away is another way of checking. If it still happens, then start removing the source lines. – llua Dec 29 '13 at 4:07
  • Thanks. I've tried turning off the plugins but no use. Definitely seems to be an oh-my-zsh issue, I finally managed to hunt this down on the issue tracker on github: github.com/robbyrussell/oh-my-zsh/issues/1028 – actionshrimp Dec 29 '13 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.