2

I've got an external drive, and I'd like to have a linux partition on it. I formatted everything correctly on one machine with Fedora20 (I have one ntfs and one ext4 partition), but when I plug it in my older machine with Fedora12, it doesn't automount the ext4 partition. I have found a solution that involves putting something like the following in /etc/fstab:

UUID=0123-abcd  /media/MYEXTDISC  ext4  ...,umask=000,dmask=000,...

But this has two problems:

  1. It doesn't help since the old machine with Fedora12 does not support umask and dmask for ext4.

  2. I would have to do something like that on every linux computer I use, which is impossible, since some of them are at work where I can't modify /etc/fstab.

My idea was that the the filesystem could provide some option like "treat all non-root files as non-root files" or "give all non-root files the rights 666 or 777. However, I don't know if this is possible with ext4. I can change the filesystem to anything linuxy, the HDD is empty at this moment.

  • with ext4 you use chmod and chown to set permissions and ownership. – Panther Dec 28 '13 at 21:25
  • @bodhi.zazen Now tell me how to do it in such a way that I can plug&play the disk on any machine. Using chmod every time I want to do something doesn't seem to be a working option... – yo' Dec 28 '13 at 21:40
  • @tohecz I'm confused as to why you have the umask and dmask. what are you trying to do? – strugee Dec 28 '13 at 21:51
  • @strugee That's a solution I have found on the internet, but it doesn't help me on the older machine (which is the 1st issue listed). It might work on the newer one, but then the 2nd issue comes to play :-/ I basically want to have a unix partition so that I can move linux files without corrupting them completely (at least I'd like to keep the x flag. – yo' Dec 28 '13 at 21:58
  • @tohecz I don't think you need those mount options for automounting... – strugee Dec 28 '13 at 22:08
2

It seems your problem is that each installation has a unique owner. Linux identifies users by number, or UID. You can see your user id with the id command:

$ id

At any rate, your first user on Fedora 20 has a UID of 1000, while Fedora 12 has a UID of 500.

You either need to relax the permissions, use a common group on each install, or use the same UID for your users.

It is possible you may be running into problems with selinux as Fedora 12 and Fedora 20 auto mount in very different locations. Check for selinux problems or set selinux in permissive mode.

With an ext4 partition, as you can see, you use chown and chmod to manage permissions.

1

If you're having a lot of issues with EXT4 perhaps you can format the partition as EXT3 instead. This should be supported on any of the distros you'll come across and Fedora 12 should be OK with this as well.

Also why do you need to worry about the filesystem type on this external drive? I would probably just make it a filesystem type that's supported across everything, even using NTFS should be fine, especially if you're just using it to shuttle data around.

Going forward I'd suggest taking the time and moving up from Fedora 12, if possible.

  • Both ext3 and ext4 are supported. But according to man mount (and my attempt with ext4), the options umask and dmask are invalid for both of them. – yo' Dec 28 '13 at 21:39
  • +1 for the suggestion to upgrade, Fedora 12 is pretty old, isn't it? – strugee Dec 28 '13 at 21:53
  • I just upgraded from F14 and that was installed in 2009-2010 I believe. So yeah it's old. 8-) – slm Dec 28 '13 at 21:56
  • @tohecz - I wasn't doubting that it wasn't supported, just that the level of support can be problematic. If I recall during my install of F14 it was giving you the option of either ext3/4 and I went w/ 4, but before that ext3 was the preferred FS b/c ext4 was still being stabilized. That was one of my rationals for delaying my migration from F10 to F14. – slm Dec 28 '13 at 21:59
  • 1
    @strugee - yeah I'd been meaning to ask Gilles if there are secret things but keep forgetting. I could see them hiding things but maybe not. – slm Dec 28 '13 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.