1

Using SL6.4, I am trying to create a new KVM virtual machine using virt-manager. When defining storage at default pool, it boots up OK. However, when trying to use storage located on external NTFS drive, it fails with permission denied.

I've changed SElinux to permissive mode, defined a directory on the NTFS drive as storage pool; (un)commented the "user" and "group" lines on /etc/libvirt/qemu.conf file, but none of these helped.

Should something with the NTFS mounting be changed? Maybe some other configuration?

EDIT:

virt-manager succeeded creating .img file on the NTFS partition (but warned me that it doesn't have search permission (??) in that directory), it failed only when trying to start the virtual machine.

Furthermore, if I try to use default storage, and read an ISO file from /home partition - it works; but when I try to use default storage and read an ISO file from NTFS partition it fails with the same failure. (the ISO file is readable from the NTFS partition. I know that because it was copied from there to /home ...)

  • NTFS doesn't support UNIX permissions. – jordanm Dec 28 '13 at 18:00
  • 2
    let's rule out KVM first - can you add a file on this NTFS volume under Linux? – Thorsten Staerk Dec 28 '13 at 18:03
2

I had the same problem. When starting VM using image stored on shared NTFS partition, I was getting:

Could not open '/path/to.qed': Permission denied

It was not a problem related to mounting the drive, but to SELinux. journalctl -xf revealed SELinux problem:

paź 05 08:45:20 everfree.forest setroubleshoot[10798]: SELinux is preventing qemu-system-x86 from open access on the file /path/to.qed. For complete SELinux messages run: sealert -l 0aaa735d-23e9-4205-b024-8b56a2b9c473
...
*****  Plugin catchall_boolean (89.3 confidence) suggests   ******************

If you want to allow confined virtual guests to read fuse files
Then you must tell SELinux about this by enabling the 'virt_use_fusefs' boolean.

Do
setsebool -P virt_use_fusefs 1

Setting the SELinux boolean fixed my problem.

| improve this answer | |
0

Problem solved, with information from https://askubuntu.com/questions/113733/how-do-i-correctly-mount-a-ntfs-partition-in-etc-fstab :

Just add 'permissions' to the mount command, and everything works.

Thanks!

| improve this answer | |
  • How does adding the word permissions to the mount command help? I can't find this documented anywhere, and not in that linked Q&A either. It says something else entirely. – Michael Hampton Apr 9 '19 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.