I'm working on Ubuntu 13.04.

I want to make backup of my data on DVD but unable to do so. To test this I'm backing up file name 'tomboy' from my current directory to DVD.

ravbholua@ravbholua-Aspire-5315:~/Documents/Other$ dd if=./tomboy of=/dev/cdrom
dd: opening ‘/dev/cdrom’: Read-only file system

Then I ran the following intending to remount it as read-write mode.

ravbholua@ravbholua-Aspire-5315:~/Documents/Other$ sudo mount -o rw,remount /dev/cdrom ~/Downloads
mount: you must specify the filesystem type
ravbholua@ravbholua-Aspire-5315:~/Documents/Other$ sudo mount -t iso9660 -o rw,remount /dev/cdrom ~/Downloads
mount: /home/ravbholua/Downloads not mounted or bad option

I don't understand why it messaged above mount: /home/ravbholua/Downloads not mounted or bad option Is my syntax wrong? Then I tried the below:

ravbholua@ravbholua-Aspire-5315:~/Documents/Other$ sudo umount /dev/cdrom
umount: /dev/cdrom: not mounted
ravbholua@ravbholua-Aspire-5315:~/Documents/Other$ sudo mount -t iso9660  /dev/cdrom ~/Downloads
mount: block device /dev/sr0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/sr0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so


I tried this with 2 DVDs but the same issue with both of them.

I need to back-up or copy data on a DVD & CD.

  • Is there a specific reason you want to do this with dd and not use a normal CD burner?
    – terdon
    Dec 28, 2013 at 15:00
  • Maybe do try dmesg | tail to see what's there, maybe a clue. Also, maybe ls /dev and look, maybe there's something else than cdrom there...
    – user44370
    Dec 28, 2013 at 15:42
  • @terdon I have SONY DVDs which aren't getting burned by a burner. I tried burning my Ubuntu 13.10 O.S. on it. The thread for this issue of burning is here. As the SONY DVDs aren't getting burned, I want to use it to copy photoes and videos. so, I'm using dd command.
    – Ravi
    Dec 29, 2013 at 6:25
  • If the burner is not working, then neither will dd. IN any case, you can't do this directly with dd, you will need mkisofs and cdparanoia or whatever the equivalent is for DVDs. I recommend you forget about dd and focus on why the disks are not recognized by your burner.
    – terdon
    Dec 29, 2013 at 11:51
  • @terdon the problem is with these DVDs. Amkette DVD & SONY DVDs which I purchased earlier worked perfectly. So these SONY DVDs which aren't working may be duplicate. Please have a look at my comment on this thread. There I have mentioned that I ran a command to check f.s. on DVDs. The command ran on working DVDs but gave error "/dev/sr0: ERROR: cannot read `/dev/sr0' (Input/output error)" when I ran on these SONY DVDs which aren't working.
    – Ravi
    Dec 29, 2013 at 12:12

1 Answer 1


You cannot just write on CD/DVD. This would be your tool for DVD http://linuxcommand.org/man_pages/growisofs1.html and this is for CD http://www.linuxjournal.com/magazine/writing-iso-images-cd-cdrecord

From growisofs man-page:

       To master and burn an ISO9660 volume with Joliet and Rock-Ridge  exten-
       sions on a DVD:

            growisofs -Z /dev/dvd -R -J /some/files

       To append more data to same DVD:

            growisofs -M /dev/dvd -R -J /more/files

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .