9

I haven't found any concise explanation of this.

  • What are the other Mono dependencies besides mono-runtime and libmono-system-windows-forms4.0-cil required to run C# Windows Forms applications on Ubuntu Linux 16.04? Thank you. – Frank May 10 '16 at 2:05
19

So you're looking for a package containing a file called System.Windows.Forms.dll. You can search:

Both methods lead you to (as of Ubuntu 14.04):

Install it with:

sudo apt-get install libmono-system-windows-forms4.0-cil
  • 1
    What are the other Mono dependencies besides mono-runtime and libmono-system-windows-forms4.0-cil required to run C# Windows Forms applications on Ubuntu Linux 16.04? Thank you. – Frank May 10 '16 at 2:05
  • 1
    +1 for teaching me how to fish. – remcycles Jul 21 '18 at 5:26
2

Open Synaptic and search for System.Windows.Forms and select libmono-winforms2.0-cil or libmono-winforms1.0-cil and then apply.

(optional) You might need to install System.Runtime package as well. just search for that and install libmono-system-runtime2.0-cil or libmono-system-runtime1.0-cil

1

Found it via this link:

% apt-get install libmono-winforms1.0-cil libmono-winforms2.0-cil

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.