3

I've been using similar config for years:

Section "InputClass"
    Identifier "keyboard-all"
    MatchIsKeyboard "on"
    Driver "evdev"
    Option "XkbLayout" "us,ru,de"
    Option "XkbVariant" ",winkeys,"
    Option "XkbOptions" "terminate:ctrl_alt_bksp,grp:ctrl_shift_toggle"
EndSection

After updating to a newer version of my distro both right Ctrl+Shift and left Ctrl+Shift switch keyboard layout only in one direction us -> ru -> de. It used to work like this before:

  • Right Ctrl+Shift: us -> ru -> de
  • Left Ctrl+Shift: us -> de -> ru (reverse order)

Is there any way to restore the old behavior?

3
  • Which file is this? Feb 3, 2017 at 16:55
  • @NickolaiLeschov a config file with any name in /etc/X11/xorg.conf.d. Mine in particular is named 90-keyboard-layout.conf.
    – UVV
    Feb 3, 2017 at 19:31
  • I don't have a directory named xorg.conf.d. Feb 4, 2017 at 12:58

1 Answer 1

2

Ok, so here is where the story starts: https://bugs.freedesktop.org/show_bug.cgi?id=42931 It seems that someone didn't like the old behavior so it was changed to one-directional.

Although man-page in my xkeyboard-config-2.6 doesn't have all the options supported, there are _bidir switch options, which you can use. Thus to restore the old behavior your config (or corresponding setxkbmap command) should look like this:

Section "InputClass"
    Identifier "keyboard-all"
    MatchIsKeyboard "on"
    Driver "evdev"
    Option "XkbLayout" "us,ru,de"
    Option "XkbVariant" ",winkeys,"
    Option "XkbOptions" "terminate:ctrl_alt_bksp,grp:ctrl_shift_toggle_bidir"
EndSection

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.