1

I'm on Ubuntu on an E1 Vision AMD (64 bit) processor.

The available binaries for Unetbootin do not work on this architecture.

Is there any way that I can get Unetbootin working on this system?

  • Compiling it from source maybe? – user44370 Dec 27 '13 at 13:17
  • @illuminÉ That worked, when I last tried it (different link), there were a bunch of errors. Care to post it as an answer? – Manishearth Dec 27 '13 at 14:01
  • Oh, that was just a link and you went through the process so maybe you have some further insights. Please proceed! – user44370 Dec 27 '13 at 14:14
  • @illuminÉ Nah, following the basic instructions in the link worked. I had followed a different link in the past, which hadn't worked. – Manishearth Dec 27 '13 at 14:17
2

In some cases, especially with smaller tools/utilities, one might resort to compiling from source.

In this case compiling as described on the wiki worked. Requirements for compiling Unetbootin v585:

  • libqt4-dev
  • g++

Instructions (make sure to check the source link)

1- Extract the tarball and cd to it

2- Run the following commands:

lupdate-qt4 unetbootin.pro
lrelease-qt4 unetbootin.pro
qmake-qt4
make

3- A dynamically linked executable which you can package will then be generated at "unetbootin"

4- If building a package, place the unetbootin_*.qm files (which were generated from the .ts files when lrelease-qt4 was run) in the /usr/share/unetbootin/ directory to enable the usage of localization.

5- If building a package, add "syslinux", "p7zip-full", "libqt4-core" (libQtCore.so.4), "libqt4-gui" (libQtGui.so.4), and "libqt4-network" (libQtNetwork.so.4) as dependencies.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.