When I run pacman -S uwsgi or pacman -S community/uwsgi I get the following error:

resolving dependencies...
looking for inter-conflicts...

Packages (6): jansson-2.5-2  libxml2-2.9.1-5  libyaml-0.1.4-3
              python2-2.7.6-1  sqlite-3.8.2-1  uwsgi-1.9.20-1

Total Download Size:    0.27 MiB
Total Installed Size:   69.85 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages ...

error: failed retrieving file 'uwsgi-1.9.20-1-x86_64.pkg.tar.xz' from
    archlinux.mirrors.uk2.net : The requested URL returned
    error: 404 Not Found
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

This would indicate to me that the package is not on the server. However I tried a number of mirrors and got the same result.

I then investigated further, by directing my web browser to the mirror directory and confirmed that there is a uwsgi package there, but the version is later:


I am fairly new to Arch so don't know if I'm missing something obvious here. On Debian my response would be to run apt-get update, but can't find a similar facility in pacman: My understanding is that the -S option will take care of that as well as installing the package.

Could this be a case of mirrors not being synced properly, or am I missing something simple at the client end?

If the mirror contains a later version, why isn't my pacman command picking that up?


Synching my local mirror database and doing a system upgrade with pacman -Syu solved it.

  • Pretty new to Arch myself. I read this in their wiki in particular a warning about partial upgrades and to never refresh the package list before installing an app. Indeed, if there was a new sync, one should do pacman -Syu before installing a package. – user44370 Dec 26 '13 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.