8

I am installing Debain Weezy (netinstall) in VirtualBOX using preseed.cfg.

I'm trying to create a preseed.cfg that would skip/not set Debian mirror in the Configure the package manager step. I am not installing any additonal packages (tasksel tasksel/first multiselect none) therefore "a very minimal base system"

If I use d-i mirror/country string manual I get

Please enter the hostname of the mirror from which Debian will be downloaded

I then have to manually select Go back and select Yes when asked Continue without a network mirror?.

Setting d-i mirror/country string boolean false gives the same dialogue.

Additionally something like d-i mirror/confirm boolean true needs to be added too I think since it's a two-step dialogue.

2

You need to set the settings of all the keys to none for it to work. Try this:

d-i mirror/country string manual
d-i mirror/http/hostname string ""
d-i mirror/http/directory string ""
d-i mirror/http/proxy string ""

This tells the installer, set the mirror in manual, the hostname is none, the directory is none, and the proxy is none.

| improve this answer | |
  • This sadly doesn't work either: "Bad archive mirror" – user55400 Dec 27 '13 at 9:20
2

I ran the installer without picking a mirror. In the resulting system, all installer options used can be found at /var/log/installer/cdebconf/questions.dat

search mirror related params in this file. mine shows

Name: apt-setup/no_mirror
Template: apt-setup/no_mirror
Value: true
Owner: apt-mirror-setup

thus the preseeding setting should be

d-i apt-setup/no_mirror boolean true
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.