3

I'm trying to set up a TP-LINK TL-WL725N v2 WiFi USB stick on my BeagleBone Black.

However, it doesn't even appear to be recognised, i.e. it doesn't show up in the output of lsusb:

$ lsusb  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Neither dmesg nor the syslog contain any new messages when the stick is plugged in or unplugged.

Oddly enough, the stick even seems to break the USB port for the rest of the session: after plugging and unplugging the WiFi stick, a memory stick that previously worked fine was no longer recognised until I rebooted the BeagleBone.

The same WiFi stick works flawlessly on a laptop running Ubuntu 12.04.3 with a 3.11.0 kernel and a Raspberry Pi running Raspbian with a 3.10.24 kernel.
Relevant lsusb line:

Bus 001 Device 006: ID 0bda:8179 Realtek Semiconductor Corp.

However, the Raspberry reboots whenever I plug in the stick, so it might be drawing too much current.

I'm not quite sure how to proceed:
does this indicate a hardware failure (presumably of the WiFi stick)? Or is there anything else I could try to at least get the stick recognised on the BeagleBone?
(I'm aware that I will have to compile the necessary kernel module myself, just like on the Raspberry Pi, but that's no use if the stick isn't even recognised...)


Edit

I've checked the supply voltage on the USB port and it is actually switched off the moment I connect the WiFi stick. I tried forcing it back on by pulling the !EN pin on the TPS2051 switch IC low, but that didn't help (i.e. the voltage came back on, but the system didn't seem to poll the bus anymore).

I've googled for the USB1_DRVVBUS output on the processor that drives the input of the switch IC and it seems that the supply for the USB host port is automatically disabled when an over-current condition is detected.

That explains why the stick crahes the Raspberry Pi and fails to work on the BeagleBone, but leaves me to wonder if it might be broken, since several Raspberry users have reported that it worked for them without a powered hub.


Second Edit

I perused the schematic some more and bypassed the switch IC and current sensing resistor, but even then the the USB host section is disabled as soon as the WiFi stick is connected.

  • 2
    Try to connect a self-powered USB hub and plug WiFi stick there. – yegorich Dec 25 '13 at 19:38
  • I'll try as soon as I can get one (probably not before Monday, due to the holidays). – n.st Dec 25 '13 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.