I'm trying to change the shortcut key for "Run Application" ( Alt+F2 ) to the Windows key.

When I click "Show the panel's Run application dialog box" in Keyboard Shorcuts, it says "New Shortcut", waiting for my key combination. I press the Windows key… and nothing happens.

  • Interestingly for me, I used to be able to do this, but not anymore. I don't know if this has anything to do with newer GNOME or X. What OS and GNOME versions are you using?
    – tshepang
    Commented Apr 5, 2011 at 13:06
  • 2
    I know this is tricky because the Meta (Windows) key is often considered a modifier key instead of a normal key. The same goes for Ctrl, Shift and Alt. But that's all I know.
    – phunehehe
    Commented Apr 5, 2011 at 15:33

5 Answers 5


try using xev command - my output after windows key pressed: If you can't see it name(Super_L in this case) you should map it. More info on archlinix wiki.

KeyPress event, serial 30, synthetic NO, window 0x4200001, root 0xb4, subw 0x0, time 4453306, (1419,619), root:(1420,662), state 0x10, keycode 133 (keysym 0xffeb, Super_L), same_screen YES, XLookupString gives 0 bytes: XmbLookupString gives 0 bytes: XFilterEvent returns: False


Probably xbindkeys is the better option. I think it's more useful to use Super_L (windows key) in combination with other key in order to fire a command. For example you could recreate the windows behaviour of firing something similar to what you want, by assigning Super_L + r to "Run application".


I've found that to do it through GNOME's shortcut config dialog, you first have to go to System -> Preferences/Administration -> Keyboard and click on the "Layout Options" button in the "Layouts" tab. Go to "Alt/Win key behavior" and select "Hyper is mapped to Win-Keys". Then the Win key can be used as a modifier.

Edit: reread the question, this won't work for just "Win" (I assumed Win+R). Sorry.


Pretty old question but with CentOS and Gnome 2.x nowadays, there is a pretty simple menu for it. It's under System -> Preferences -> Keyboard Shortcuts and you just have to choose the choice "Desktop" and then under that, "Run Dialog". When you click it, it lets you press the keys you want. It originally has "ALT+F2" listed but if you happen to choose the right Windows key + R, it says "Mod4+R" under the shortcut area and works like a champ.


You can do this by running gconf-editor:

and navigate to


and change it's value to "Super_L" or "Super_R"

If you want both to work at the same time, you have to assign Super_R to Super_L or vice versa.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .