4

I have a laptop running Ubuntu 13.10. It was running fine till yesterday when I installed OpenCV 2.4 using Synaptic (if that is of any relevance since there is no other change in configuration). This morning, I powered it on and it comes to the screen asking for login, even showing my background correctly. However, after I login, the screen goes blank. I can see the mouse cursor and it moves when I use the trackpad, but I am unable to do anything else. I am not able to start terminal window or anything else because I do not have any icon. From the login screen, I tried to change to Gnome (instead of Ubuntu default) but still, had no luck. Can someone please help?

There should be a command to go into non-GUI mode but I cannot recall that either.

The output from lspci | grep VGA is

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primart) (rev 0c)

Looks like it is unable to load Plugin opengl which must be because of my install of OpenCV.

apt-cache policy nvidia

nvidia:
  Installed: (none)
  Candidate: (none)
  Version table:

apt-cache policy fglrx

fglrx:
  Installed: (none)
  Candidate: 2:13.101-0ubuntu3
  Version table:
     2:13.101-0ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ saucy/restricted amd64 Packages

If it is of any help, I typed the command glxinfo and got the error:

Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
9
  • Are you able to use another machine to ssh into your laptop, by any chance? Maybe that will help you?
    – Kevdog777
    Dec 23, 2013 at 16:15
  • 2
    Cay you get into a tty? (Ctrl+Alt+F1)? If so try running DISPLAY=:0 unity --replace or just DISPLAY=:0 unity.
    – Seth
    Dec 23, 2013 at 16:17
  • I was able to go in using Ctrl+Alt+F1. I tried startx but it gave me an error sau=ying extension GLX missing. When I tried @Seth's suggestion, it gave me a bunch of errors with compiz (decor) - Warn: requested a pixmap type decoration when compositing isn't available followed by Xlib: extension "GLX" missing on display ":0"
    – unxnut
    Dec 23, 2013 at 16:24
  • Can you edit the output of lspci | grep VGA into your question please?
    – Seth
    Dec 23, 2013 at 16:28
  • @Seth, I just updated the question with the suggested edit.
    – unxnut
    Dec 23, 2013 at 16:32

1 Answer 1

2

After examining your Xorg.0.log, it appears that Xorg is attempting to load the glx module with the nvidia drivers, and since you don't have an Nvidia card it's failing to load. Removing the Nvidia packages should solve your issue:

sudo apt-get purge nvidia-common nvidia-settings-319-updates nvidia-319-updates

Then restart.

In case you're interested, here are the important lines in your Xorg.0.log:

[    26.590] (II) "glx" will be loaded by default.  
...  
[    30.675] (II) LoadModule: "glx"
[    30.675] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[    31.137] (II) Module glx: vendor="NVIDIA Corporation"
[    31.137]    compiled for 4.0.2, module version = 1.0.0
[    31.137]    Module class: X.Org Server Extension
[    31.137] (II) NVIDIA GLX Module  319.60  Wed Sep 25 14:24:11 PDT 2013
[    31.138] Loading extension GLX  
...  
[    31.250] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)  

This Ubuntu Forums thread was very useful in figuring this out.

5
  • This worked. I have a GUI. However, I do not have any decorations on the windows, nor do I have the tabs containing commands to be run on the side (toolbar). Can you suggest what do I need to get the toolbar back? And my window decorations?
    – unxnut
    Dec 24, 2013 at 4:49
  • I am able to use the machine nicely by changing over to Gnome desktop but cannot use the Ubuntu default. Any suggestions?
    – unxnut
    Dec 24, 2013 at 5:13
  • @unxnut Are you experiencing something like this? If not, a screenshot would help :)
    – Seth
    Dec 24, 2013 at 16:21
  • Not exactly. I have all the icons of items on my desktop but that is pretty much it. If I double click on an icon, it opens up the document appropriately. However, I do not have any surrounding border and so, cannot minimize it. I also do not have a toolbar on the side. For now, I am using the Gnome desktop but I liked Unity better.
    – unxnut
    Dec 24, 2013 at 16:36
  • What you are describing seems exactly like that question. The launcher and dash don't appear, but everything else works.
    – Seth
    Dec 24, 2013 at 16:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .