6

I have removed network-manager and am trying to configure Wi-Fi with WEP manually. I am running on an X1 Carbon.

Here are the commands I am running:

ifconfig wlan0 down
iwconfig wlan0 essid "<MYSSID>"
iwconfig wlan0 key <WEP Key (hex digits>
ifconfig wlan0 up
dhclient -v wlan0

The output of dhclient -v is a stream of

DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3  
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5

Here is the output of dmesg | tail (mac address removed)

[  739.160769] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  742.280433] wlan0: authenticate with <router_mac_address>
[  742.288117] wlan0: send auth to <router_mac_address> (try 1/3)
[  742.290519] wlan0: authenticated
[  742.290615] iwlwifi 0000:03:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
[  742.290632] wlan0: waiting for beacon from <router_mac_address>
[  742.378124] wlan0: associate with <router_mac_address> (try 1/3)
[  742.581910] wlan0: associate with <router_mac_address> (try 2/3)
[  742.785611] wlan0: associate with <router_mac_address> (try 3/3)
[  742.989382] wlan0: association with <router_mac_address> timed out

Here is the output modprobe -l | grep iwl

kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
kernel/drivers/net/wireless/iwlwifi/dvm/iwldvm.ko
kernel/drivers/net/wireless/iwlegacy/iwlegacy.ko
kernel/drivers/net/wireless/iwlegacy/iwl4965.ko
kernel/drivers/net/wireless/iwlegacy/iwl3945.ko

Please let me know if additional information would help, or if there's some step I'm missing. I have tried the same steps on Ubuntu 13.10, but I get the same result.

Update 1: While I am running dhclient wlan0 in one terminal, I have tcpdump -i wlan0 -nl in a different terminal. tcpdump does not see a single packet actually go out.

Update 2:

Here is the output of lshw -C network

 *-network               
       description: Wireless interface
       product: Centrino Advanced-N 6205 [Taylor Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 96
       serial: <mac_address>
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.11.0-14-generic firmware=18.168.6.1 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
       resources: irq:43 memory:f0c00000-f0c01fff

Also, iwlist wlan0 scan works fine.

4
  • Have you tried the modern tool iw?
    – yegorich
    Dec 22, 2013 at 20:42
  • Yes. Same results.
    – merlin2011
    Dec 23, 2013 at 1:31
  • I don't think it would solve the problem, but have you also tried wpa_supplicant?
    – yegorich
    Dec 23, 2013 at 7:24
  • I tried killing wpa_supplicant.
    – merlin2011
    Dec 23, 2013 at 19:21

1 Answer 1

1

In your /etc/network/interfaces file add wireless-mode managed and it should be working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .