2

I am on Linux Mint 15 (Mate). I installed Compiz following the steps in this tutorial. Then due to some problems I faced, I decided to disable it. So I executed the following command:

metacity --replace

Then removed compiz --replace from the Startup Applications and reverted org > mate > desktop > session > required-components > windowmanager back to marco. After logging out and logging in again, I realized that none of my windows have any title bar. What should I do?

enter image description here

p.s. When I click the show desktop icon, the following error appears:

enter image description here

10
  • I assume you have marco installed (not metacity; I'm assuming macro was a typo)?
    – strugee
    Dec 24, 2013 at 9:08
  • @strugee Yes the default window manager of MATE is apparently macro and as far as I know macro is somehow related to metacity. There is no macro in /usr/bin though.
    – B Faley
    Dec 24, 2013 at 9:39
  • Marco is a fork of Metacity. also, you keep saying "macro" instead of "marco" - that is a typo, right?
    – strugee
    Dec 25, 2013 at 0:41
  • @strugee Thank you for correcting me. I thought it's macro. Shame on me :)
    – B Faley
    Dec 25, 2013 at 5:27
  • 1
    @slm No problem :)
    – B Faley
    Jan 20, 2014 at 21:15

2 Answers 2

1

Per a comment discussion below the question, asker thought the window manager was called Macro instead of Marco, and thus got the binary name wrong.

-1

You might want to install the 'CompizConfig Settings Manager', go to the 'effects' page and make sure that the 'Window Decoration' checkbox is checked.

1
  • 2
    he said he disabled Compiz. the problem is somewhere else.
    – strugee
    Dec 25, 2013 at 0:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.