2

Yesterday I was using my FC18, of which I haven't updated significant packages for long time, maybe just a few desktop apps some weeks ago. On shutdown I chose to hibernate it, as I usually do and as I have been doing for months almost daily.

Today I turned it on just to have X hanging after boot. I tried hard reboot, passing the noresume option to grub so that it didn't use the booting data on swap, summoning a login screen and then shutting down by command-line, etc... Nothing changes. Everything loads, even wpa-supplicant, gdm..., at least according to the messages displayed on boot, and then I still end up stuck on a default wallpaper with my working mouse pointer.

On the second time I tried rebooting a graphical message, with a sad-faced computer, appeared saying "It seems an error occurred, contact administrator." If I try to start X again on another login screen via startx it still hangs.

I have made no recent changes to X or system's configuration, nor any important update. The only thing I did differently from usual was hibernating while having some more videos running: a video file played on VLC and some Firefox tabs with flash videos, which, however, were not playing all together at the same time. I usually hibernate after having closed a few apps, that's it.

Do you have any idea on what's going on? what should I check to fix the problem?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.