1

I have a Mac running VMware Fusion 5.0.4 on OSX Mavericks, and I do not seem to be able to get past a certain point on installation on either of two installers I tried.

A (text) window comes up, labelled 'System Configuration Tool', with options of 'F2_Continue', 'F6_Help', and 'F9_Quit'. The text of the initial screen says, 'If your keyboard does not have function keys, or they do not respond, press ESC; the legend at the bottom of the screen will change to show ESC keys for navigation and other functions.'

I haven't been able to get past this screen or get any change to register in a way that makes a difference to the screen. F2, F6, and F9 do their usual Macintosh effects and nothing else I can discern; hitting escape, or manually hitting ^ + [, made no observable change.

I'm not sure how far I trust function keys under VMware, but escape has otherwise worked. Other forms of input, chiefly hitting return, have had the desired effect.

How under VMware Fusion on Mavericks can I get past this point of the installation? No VMware Tools have been installed on the VM; I haven't logged in or gotten past this point in setup.

  • Have you tried shift+F2? – ludiegu Dec 22 '13 at 15:31
  • Thank you; just tried shift-F2 and control-F2. Nothing discernible. – Christos Hayward Dec 22 '13 at 21:09
  • Glad to help. Could you answer your question to provide the solution for community? :) – ludiegu Dec 23 '13 at 15:07
  • Sorry; I meant that I tried shift-F2 and control-F2 and saw no discernible effect / improvement. – Christos Hayward Dec 23 '13 at 18:00
  • Does kb.vmware.com/selfservice/microsites/… help? By default, you need to hold down the 'fn' key, usually in the lower left corner of the apple keyboard, along with the desired function key, to send that keycode to the VM – Mark Plotnick Jan 4 '14 at 12:48
0

I ran into this issue myself when installing Solaris 11.3 on VirtualBox.

The solution is to press Fn+F2 instead of just F2.

On keyboards with an FnLk or FnLock key, enabling Fn-lock ("function lock") will make the function keys behave as the Solaris installer expects them to, without having to press Fn.

macOS allows you to enable Fn-lock in the "System Preferences" under "Keyboard".

-2

To Go Forward: Esc + 2

To go back: Esc + 3

To reboot: Esc + 8

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.