4

I am using Sublime Text 3 which uses CtrlAlt$key hotkeys for a few important functionalities, but CtrlAltLeft (for example) switches workspaces. Is there a way I can disable the OS functions of these hotkeys while I'm using Sublime Text 3?

I'm running Linux Mint 16 Petra with Cinnamon desktop, and the latest version of Sublime Text 3

  • this highly depends on your desktop environment. When using KDE try the command systemsettings. There you will find settings for the keyboard including hotkeys. – Thorsten Staerk Dec 20 '13 at 6:28
  • While it's not exactly what I was looking for, I was able to change the hotkeys through the System Settings > Keyboard menu. – Jehy Dec 20 '13 at 7:26
  • Not sure if Cinnamon has anything similar, but KDE has this: unix.stackexchange.com/a/79513/28489 . Also this, but does not seem to apply to Ctrl+Alt+Arrow though: sublimetext.userecho.com/topic/89378-support-unbinding-of-keys (As in it is not captured by Sublime, at least in my tests.) – Runium Dec 20 '13 at 9:36
1

You can simply un-map the keys.

Run dconf-editor. Head to org.cimmamon.muffin.keybindings. And empty or change the conflicting key bindings.

I recommend you edit the keybindings in Sublime Text though.

edit

org.cinnamon.desktop.keybindings.wm

'cause

org.cinnamon.muffin.keybindings

seems to be deprecated

enter image description here
/edit

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.