I'm trying to install CentOS 6.5 in Virtual Box. The problem is, the installation hangs on the first screen after waiting about 10 seconds.

How can I pass this screen?

The steps I installed:

1) Create virtual machine

enter image description here

2) Start it

It shows "Automatic boot in 10 seconds" and count down, then it freezes as below

CentOS 6.5 Installation Screen

After many times failing, I tried to press Print key. It shows multiple options, choosing any option causes hanging. The only selectable option is "Install (Text Mode)", press it, it shows "This kernel requires an x86-64 CPU, but only detected an i686 CPU. Unable to boot - please use a kernel appropriate for your CPU".

  • 2
    Have you configured the VM with multiple CPUs? Try reducing it to a single virtual CPU, then restart the installation. – Warren Young Dec 19 '13 at 8:58
  • 1
    You could try to start the text-type installation. – ludiegu Dec 20 '13 at 8:36
  • That looks like a splash screen. Press f2 to see console messages and possibly a hint as to why it's hanging. – laebshade Dec 22 '13 at 2:56
  • @WarrenYoung It was 1 CPU. I tried to press F1 -> F12 but nothing happens. – emeraldhieu Dec 23 '13 at 1:38
  • From the GUI, it needs to be <kbd>Alt-F2</kbd>, etc. – Warren Young Dec 23 '13 at 5:20

The solution depends on whether you have 32-bit or 64-bit processor on your computer.

  • If you have 32-bit processor (and therefore 32-bit OS) on your computer, then you can't run 64-bit guest OS on VirtualBox. Use CentOS' 32-bit version (CentOS-6.5-i386-LiveCD.iso) instead.

  • If you have 64-bit processor and 32-bit OS on your computer, then you're able to run 64-bit guest OS in Virtualbox. Just do the following steps:

    • Enable the checkbox "Enable VT-x/AMD-V" in the guest OS' settings.
    • Enable hardware virtualization in BIOS.
    • Choose "Red Hat (64-bit)", not just "Red Hat" in the screen which appears in the beginning of the creation of new virtual machine.
  • If you have 64-bit processor and 64-bit OS on your computer, then you don't have to do anything special to run 64-bit guest OSes on VirtualBox: just create one and run it.

Excerpt from VirtualBox's guide, Chapter 3 which explains all my points:

VirtualBox supports 64-bit guest operating systems, even on 32-bit host operating systems, provided that the following conditions are met:

  1. You need a 64-bit processor with hardware virtualization support (see Section 10.3, “Hardware vs. software virtualization”).

  2. You must enable hardware virtualization for the particular VM for which you want 64-bit support; software virtualization is not supported for 64-bit VMs.

  3. If you want to use 64-bit guest support on a 32-bit host operating system, you must also select a 64-bit operating system for the particular VM. Since supporting 64 bits on 32-bit hosts incurs additional overhead, VirtualBox only enables this support upon explicit request.

    On 64-bit hosts (which typically come with hardware virtualization support), 64-bit guest operating systems are always supported regardless of settings, so you can simply install a 64-bit operating system in the guest.


I was able to install CentOS 6.5 on Virtual Box 4.3.8 hosted by Windows 8.1, using the settings shown below.

I let the live boot load up and used the desktop icon to install it to the hard disk.

Virtual Box Settings:

  • General
    • Basic
      • Type: Linux
      • Version: Red Hat(64 bit) <<< version should be 64 bits
  • System
    • Motherboard
      • Base memory: 2048 MB
      • Chipset: PIIX 3
      • Pointing Device: PS/2 Mouse
      • Extended features:
        • [x] Enable I/O APIC
        • [x] Hardware Clock in UTC time
    • Processor
      • Processors: 1
      • Extended featuress: [x] Enable PAE/NX
    • Acceleration
      • [x] Enable VT-x/AMD-v
      • [ ] Enable EFI
      • [x] Enable Nested Paging
  • Display
    • Video
      • Video Memory: 64MB
      • Monitor count: 1
      • Extended features:
        • [x] Enable 3D acceleration
        • [ ] Enable 2D acceleration
  • Storage:
    • Controller: IDE
      • Type PIIX 4
      • [x] Use Host I/O cache
      • CentOS-6.5-x86_64-LiveDVD.iso <<< iso should be for 64 bits
    • Controller: SATA
      • Type AHCI
      • Port count 1
      • [ ] Use Host I/O cache
      • CentOS_16GB_HDD.vdi
  • Audio
    • [x] Enable audio
      • Host audio driver: Windows DirectSound
      • Audio Controller: Intel HD Audio
  • Network
    • Adapter 1
      • [x] Enable Network adapter
      • Attached to NAT
      • Adapter type: Intel PRO/1000 MT Desktop (8254OEM)
      • Promiscuous mode: deny
  • Serial Ports
    • Port 1
      • [ ] Enable serial port
  • USB
    • [ ] Enable USB controller

Virtual Box 4.3.8 settings

  • @Chris, it goes beyond of "it worked for me" providing settings known to work and describes how the installation was done. Given that the OP doesn't have provide much detail I tried to provide enough information to work as a guide. – Elfdragore Dec 23 '13 at 16:08
  • It doesn't work. I tried to modify all the values you said but it doesn't work. – emeraldhieu Dec 24 '13 at 7:29
  • @Emerald214 could you edit your question and tell us more about the problem: * what CentOS ISO are you using? * what boot option are you selecting? * describe all steps you do until the it freezes – Elfdragore Dec 26 '13 at 16:28

As explained here in the context of Ubuntu:

  1. Make sure you selected 64 bit OS in the general settings\basic tab in Virtualbox
  2. If you enable VT-x/AMD-V in VirtualBox, make sure you enable it in your bios too

I ran into exactly the same problem, trying to use the image CentOS-6.5-x86_64-LiveCD.iso on VirtualBox.

My host system is Windows 7 64bit.

The issue was that VirtualBox had selected "RedHat" as the default OS for the Guest. Changing it to RedHat(64bit) solved the issue.


It's hard to tell what is going on without more information. You might be able to work around this by using the VNC install mode: http://www.ispexperts.com.np/?p=1075


I just ran into a similar problem with the RHEL 7 beta. What fixed it for me was going into the System settings on the VM and changing the chipset from PIIX 3 to ICH 9.

I also changed the Ethernet driver from the Intel desktop MAC chip to the server MAC, but I don't think this was the critical change.


Disable HyperV from Windows Features on Control Panel. Then restart and try again.


Had this same problem, turned out it was the virtual machine "version" I was using in VirtualBox.

The new VM wizard defaults to the built in "Red Hat" version when you mention Centos in the virtual machine name (a nice convenience actually). What it fails to mention is that this version profile is intended for a 32 bit version. The next option ("Red Hat (64 bit)") in the list has 64bit support. Try changing that in the VM setting and it should boot right up.

The wizard detects that I used 'Centos' in the name of my VM, so defaults to 'Red Hat' as the version

But as you can see the one you want for 64bit support is hiding right after it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.