How do I grant read, write and execute to specific group?

What I did:

adduser test
addgroup developer
setfacl -m g:developer:rwx /opt/spago41/

When I login as test I can't run:

startup.sh in /opt/spago41/

Is the setfacl command not working?

  • 1
    Have you added test user in developer group ?
    – SHW
    Dec 19, 2013 at 6:48
  • @SHW yes sir !!!!!!
    – kinkajou
    Dec 19, 2013 at 9:15

3 Answers 3


I think you were missing the "recursive" parameter:

setfacl -Rm g:developer:rwx /opt/spago41/

# useradd -G developers test

Use the below command if ther user test is already created.

# usermod -a -G Developer test

This will solve your problem. As you haven't appended the user test in developer group, and you set ACL to group developer, which doesn't have user test in it.
Attribution: SHW


Check 1#

As @SHW suggested in comments check that test user is exists or not in Developer Group

Check 2#

File System mounted with acl option or not.

from man mount:

          Support POSIX Access Control Lists (or not).

you can check using mount command

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .