0

I have a very basic question here. This thing is puzzling me a little bit.

I have two machines, one is my local desktop running Windows and I have cygwin installed in it and second machine I have is in staging domain in our company which is running Ubuntu 12.04.

I started Netflix Exhibitor like this in my desktop through CYGWIN -

david@desktop /cygdrive/c/ApacheExhibitor/Exhibitor-1.5.1/target
$ java -jar exhibitor-1.5.1-jar-with-dependencies.jar -c file
v1.5.1
INFO  com.netflix.exhibitor.core.activity.ActivityLog  Exhibitor started [main]
INFO  org.mortbay.log  Logging to org.slf4j.impl.Log4jLoggerAdapter(org.mortbay.log) via org.mortbay.log.Slf4jLog [main]
INFO  org.mortbay.log  jetty-1.5.1 [main]
Dec 18, 2013 6:07:37 PM com.sun.jersey.server.impl.application.WebApplicationImpl _initiate
INFO: Initiating Jersey application, version 'Jersey: 1.9.1 09/14/2011 02:36 PM'
INFO  org.mortbay.log  Started SocketConnector@0.0.0.0:8080 [main]

And then I went to chrome browser and I opened this URL -

http://localhost:8080/exhibitor/v1/ui/index.html

after that, I can see Exhibitor console up and showing me everything which it should be showing in my desktop.

Now I did the same thing in my Ubuntu machine which is in staging domain in our company. With the below command I started Exhibitor -

cronusapp@phx5qa01c:/zook$ java -jar ./exhibitor-1.5.1/lib/exhibitor-1.5.1-jar-with-dependencies.jar -c file
v1.5.1
INFO  com.netflix.exhibitor.core.activity.ActivityLog  Exhibitor started [main]
INFO  org.mortbay.log  Logging to org.slf4j.impl.Log4jLoggerAdapter(org.mortbay.log) via org.mortbay.log.Slf4jLog [main]
INFO  org.mortbay.log  jetty-1.5.1 [main]
Dec 18, 2013 7:10:35 PM com.sun.jersey.server.impl.application.WebApplicationImpl _initiate
INFO: Initiating Jersey application, version 'Jersey: 1.9.1 09/14/2011 02:36 PM'
INFO  org.mortbay.log  Started SocketConnector@0.0.0.0:8080 [main]

And then I went to chrome and I opened the url like this with the machine hostname -

http://phx5qa01c.stratus.phx.qa.host.com:8080/exhibitor/v1/ui/index.html

And this url is showing me blank white page on the screen.

Now I am not sure why this is happening. Is there any file which I am supposed to modify in my Ubuntu box to recognize the hostname so that it can show me the Exhibitor console page as I cannot use localhost now on the chrome?

I am pretty much sure I am missing very minor thing here..

UPDATE:-

HOSTNAME of my ubuntu machine -

cronusapp@phx5qa01c:/zook$ hostname -f
phx5qa01c.stratus.phx.qa.host.com
3
  • If there is a firewall, NAT or some filtering device between your local machine and your staging host, traffic to 8080 might not be making it through.
    – casey
    Dec 19 '13 at 3:10
  • Also, just because phx5qa01c thinks its hostname is phx5qa01c.stratus.phx.qa.host.com, doesn't necessarily mean that you will be able to use that name. Have you tried accessing your staging server by IP address? Dec 19 '13 at 3:16
  • @GregHewgill.. Awesome.. With the IP Address it works fine... Now is there any way I can start using hostname instead of IP Address?
    – SSH
    Dec 19 '13 at 3:27
2

Based on the clarifying comments above, your DNS resolver is apparently unaware of the name phx5qa01c.stratus.phx.qa.host.com. You have two general choices:

  • Talk to your DNS administrator and see whether they can make that name available for you to use, or suggest a different name that would work
  • Add phx5qa01c.stratus.phx.qa.host.com to your local /etc/hosts file

Your local /etc/hosts file is consulted for name lookups in addition to DNS (subject to the rules in /etc/nsswitch.conf). You can add a line in /etc/hosts for your phx5qa01c.stratus.phx.qa.host.com host that translates the name to that server's IP address.

If you are using Cygwin as you suggest, then the above instructions may not apply and you'll have to ask somebody else how to do the same thing for Cygwin.

4
  • I am using CYGWIN in windows which works fine there. But in ubuntu I am just using plain linux commands.. I can try your second option..
    – SSH
    Dec 19 '13 at 3:48
  • Note that you would need to edit /etc/hosts on the computer where you're running your browser, not on the server computer (the server can't influence how the browser looks up names). Dec 19 '13 at 3:49
  • The browser that I am running is my desktop which is windows..
    – SSH
    Dec 19 '13 at 3:50
  • Oh, well in that case you'll have to use a Windows-specific solution which is out of scope for this site. There is a functionally equivalent hosts file somewhere in Windows that you can edit. Dec 19 '13 at 3:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.