I'm installing Globus Toolkit . When i try to setup Certificate , this error comes :

ERROR: could not run build command: /usr/local/globus-5.0.3/sbin/gpt-build -force /home/globus/.globus/simpleCA//globus_simple_ca_2e0087ee_setup-0.20.tar.gz

I think this may be due to denial of permission. I tried executing the file with 'sudo' . It says

globus is not in sudoers file . This incident will be reported

I tried adding globus user to sudoers file .

For your reference , /etc/group file :



(I'm using Linux Mint debian . user arul has sudo privilege . But i've to install Globus in the globus user)

  • 1
    While phunehehe has answered your question, I doubt you really need to build Globus as root. If you describe precisely what you've been doing (what leads up to this error), people might be able to figure out what caused your build to fail. – Gilles 'SO- stop being evil' Apr 4 '11 at 19:23

After you add the user to sudoers, that user needs to log out and log back in for the changes to take effect. So, simply logging out and in should give your globus user sudo rights.

I'm assuming that you have the correct configuration in /etc/sudoers. To make globus a sudoer you need the line:

globus ALL=(ALL) ALL

Or you need to add globus to the wheel group and then have the line:

%wheel ALL=(ALL) ALL

Or some equivalent.

| improve this answer | |
  • Im adding the sudoers file : – vettipayyan Apr 4 '11 at 6:14
  • root ALL=(ALL:ALL) ALL %sudo ALL=(ALL:ALL) ALL %admin ALL=(ALL:ALL) ALL – vettipayyan Apr 4 '11 at 6:15
  • the user globus is in admin group - u can see that above . Have i done wrong in sudoers file ? – vettipayyan Apr 4 '11 at 6:16
  • Yeah solved !!! . I added as your instr : globus ALL=(ALL) ALL . It worked . Thank you . thank u – vettipayyan Apr 4 '11 at 6:20
  • @vettipayyan That's good :) Also see this answer on a related question. – phunehehe Apr 4 '11 at 6:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.