2

I am getting the below mentioned error while I am running "sudo apt-get update" command.

Fetched 1,592 kB in 4min 5s (6,489 B/s)
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_universe_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.

I have no idea what is this? any help?

Please notice that running below commands have no effect on the problem.

$ sudo rm -rvf /var/lib/apt/lists/*  

$ sudo apt-get update

First command run successfully while the other fails (complete output is here -> http://paste.ubuntu.com/6589940/).
What I am able to figure out is that second command (apt-get update) download the package

"precise-security_universe_i18n_Translation-en"

and then try to install it. Problem is in this package. I think this package is corrupted.

This will also prevent opening package manager and software center. If I manually delete this package then both are opening. But then again running update command will lead to same problem.

Is there anything like I can update from another server (using command line) (instead of default server used by apt-get update) where this package might be uncorrupted.

  • Restart and try. It might solve your problem. – Ruban Savvy Dec 17 '13 at 9:52
  • No. It didn't solved the issue. – Anurag Rana Dec 17 '13 at 10:00
5
sudo rm /var/lib/apt/lists/* -vf && sudo apt-get update

Will do the trick. See the source

  • Foudn similar thing here, and added a copy in as it refers to a bug report - :-) +1 – Wilf Dec 17 '13 at 13:48
  • @RubanSavvy - first part of command worked fine, I used -r switch to remove the directories as well. output- paste.ubuntu.com/6589836 However second part is still causing the same problem. output - paste.ubuntu.com/6589940 – Anurag Rana Dec 17 '13 at 17:27
  • I updated the problem. these things are not working with me. – Anurag Rana Dec 19 '13 at 8:43
  • chmod 755 /var/lib/apt/lists && chmod 755 /var/lib/apt/lists/partial Execute this command. – Ruban Savvy Dec 19 '13 at 9:14
  • Goto /var/lib/apt/lists and ls can you see some files there? – Ruban Savvy Dec 19 '13 at 9:15
3

This is a common problem it seems on the AskUbuntu forum - basically:


These terminal commands should solve your problem:

First remove the Merge List by opening a terminal (Press Ctrl+Alt+T to launch) and run this command:

sudo rm /var/lib/apt/lists/* -vf

Next, generate a new one by running a simple update:

sudo apt-get update

Here is the bug report (and another) for this problem, which is now fixed so it shouldn't create new malformed files, however if you already have the malformed files you need to remove them as explained in this post.

  • Not working. Updated the question. – Anurag Rana Dec 19 '13 at 8:43
2

Prolem Solved !

All packages were getting downloaded from a server in Lanka. Changing the server to https://archive.linux.duke.edu/ubuntu worked fine.

Step 1 - Run the command

# rm -rvf /var/lib/apt/lists/

Step 2 - open the package manager and change the server. Setting -> Repository -> Download from .

enter image description here

Step 3 - Run the command

# apt-get update

Done!!

  • Well done... :-) – Wilf Dec 19 '13 at 14:09
0

The file mentions in the error messages may be corrupted or contains a reference to an invalid/missing package header.

The file's contents looks like this:

Package: apport-kde
Description-md5: c8fd570a74a013e8fc3c502dd64152ce
Description-en: KDE frontend for the apport crash report system
 apport automatically collects data from crashed processes and
 compiles a problem report in /var/crash/. This utilizes the crashdump
 helper hook provided by the Ubuntu kernel.
 .
 This package provides a KDE frontend for browsing and handling the
 crash reports.

Package: apport-noui
Description-md5: 679b8a64ce43a788744dbacfc594051c
Description-en: tools for automatically reporting Apport crash reports
 apport automatically collects data from crashed processes and
 compiles a problem report in /var/crash/. This utilizes the crashdump
 helper hook provided by the Ubuntu kernel.
 .
 This package provides an upstart job for automatically reporting new Apport
 crash reports when enabled.

....

I'd suggest you find the section Package: header and remove it (back up the file first).

  • You got the problem backwards. He has a section with no package, and the section is called header. – Braiam Dec 17 '13 at 12:21
  • Yes right. Any idea how can I solve this problem. I updated the question. – Anurag Rana Dec 19 '13 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.