1

My setup is as follows:

Octave 3.6.4 Mac OS X Mavericks 2009 Macbook Pro

I'm trying to run Octave in Terminal, with gnuplot. I'm trying to plot matrices in a graph, as part of an online Coursera Machine Learning course.

I'm getting the following error when opening Octave in Terminal:

warning: unable to open X11 DISPLAY

I've opened XQuartz, I've set display using export DISPLAY=:0.0.

After extensive searching, I thought the problem might be that the X server wasn't running. I've tried using the command startx, although it just hangs on waiting for X server to begin accepting connections.. and eventually gives up.

I'm lost - any ideas?

migrated from stackoverflow.com Dec 16 '13 at 20:32

This question came from our site for professional and enthusiast programmers.

  • 1
    Don't know what could cause this, but you can try to use the wxt terminal. – Christoph Dec 15 '13 at 12:25
  • Thanks Christoph, that worked a treat. I reinstalled the +wxt version of gnuplot using MacPort, this answer helped me out too: stackoverflow.com/a/13665181/2742630 If you respond as answer I'll mark it as the correct one! Thanks – user2742630 Dec 15 '13 at 23:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy