5
hume@linux-o1dm:~> gnomesu -u legum java -jar '/home/legum/frem/frem.jar'
Unknown option -jar

I want -u for gnomesu and -jar for java, but the openSUSE treat -u -jar only for gnomesu.

What is the correct way of putting this on the command-line?

1 Answer 1

5

Try quotes this way:

gnomesu -u legum "java -jar '/home/legum/frem/frem.jar'"

or (not sure gnomesu supports this):

gnomesu -u legum -- java -jar '/home/legum/frem/frem.jar'

Many commands interpret -- as end of options, start of arguments

1
  • 1
    Either should work.
    – bahamat
    Dec 16, 2013 at 7:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .