5

I am trying to install GNU M4 on my Chromebook using the 1.4.17 tarball, but when I run ./configure and thenmake I get an error related to aclocal, which is apparently part of the GNU Automake package. The exact error I get is

WARNING: 'aclocal-1.14' is missing on your system.
         You should only need it if you modified 'acinclude.m4' or
         'configure.ac' or m4 files included by 'configure.ac'.
         The 'aclocal' program is part of the GNU Automake package:
         <http://www.gnu.org/software/automake>
         It also requires GNU Autoconf, GNU m4 and Perl in order to run:
         <http://www.gnu.org/software/autoconf>
         <http://www.gnu.org/software/m4/>
         <http://www.perl.org/>
make: *** [aclocal.m4] Error 127

I know the first part is only a warning, but the name indicates that the error is related.

I also tried to create an empty file for aclocal.m4, and I get a different message: a warning about automake-1.14 missing and make: *** [Makefile.in] Error 1

Unfortunately, according to the official page, Automake requires Autoconf, which in turn requires M4. What can I do to install M4 and avoid this problem?

  • isn't there a m4 package in your linux distro? – user55518 Mar 10 '14 at 17:49
  • If there was, I wouldn't have this problem. The built in Chromebook operating system has the bare minimum of useful packages, and it does not include any development packages. – murgatroid99 Mar 10 '14 at 18:07
  • since this is SUSE Linux, aren't there packages that will run on Chromebook? – user55518 Mar 11 '14 at 16:48
  • I don't know why you say it is SUSE Linux. As far as I can tell, Chrome OS is a heavily modified distribution of Gentoo, which I have no other experience in. – murgatroid99 Mar 11 '14 at 16:52
  • I installed Cr_OS_Linux.i686-2.4.1290.iso and it is Open SUSE. But I've heard also Google switched from Ubuntu to Gentoo. – user55518 Mar 11 '14 at 16:57
0

The configure file in m4 and subsequent make requires neither m4 nor aclocal, unless one of the files it mentioned has changed, which probably isn't the case.

So the likely cause is (I had this last week) a timestamp problem.

Did you copy the extracted archive into a newer directory? Is the system clock correct?

I built m4 (same version) on my system with aclocal and m4 removed, but if acinclude.m4 and configure.ac were older (touch --date="last friday" configure.ac) it returns the same error.

Remove the directory, re-unpack (maybe with tar's -m option) and try again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.