I just installed Yellow Dog Linux 6.2 on an old PowerPC laptop.

By default, it's interpreting trackpad taps as clicks, which I want to disable.

I followed the directions here, and put TRACKPAD_OPT=notap in my /etc/sysconfig/mouse-emulation and rebooted, but taps are still interpreted as clicks. Putting the setting in /etc/sysconfig/mouse instead (which I had to create) and rebooting didn't fix the problem either.

I also tried:

% sudo trackpad notap
writing /dev/adb: No such device or address

So that didn't seem to work.

What should I do?


Admittedly it's been awhile since I've used YDL but as I remember it, it should go in /etc/sysconfig/mouse not /etc/sysconfig/mouse-emulation. Perhaps that is worth a try.

  • Nope, didn't work. – rampion Apr 12 '11 at 13:30
  • Are you getting any errors at all? – rfelsburg Apr 12 '11 at 14:56
  • Not that I can see during boot. Any logs I should check? – rampion Apr 12 '11 at 15:07
  • I would look at where syslog routes your kernel facility, your info level logs. – rfelsburg Apr 12 '11 at 15:27

I don't know how it goes in Yellow Dog Linux, so my answer might not help you. Anyway ...

I have an old PowerPC Mac too (iBook G4) running Ubuntu, and disabled the trackpad click using:

sudo trackpad notap

I guess you need the program trackpad to be installed. It comes with the mouseemu package in Ubuntu. If the software is the same in Yellow Dog, you should have that command too.

Now, a quick googling for "yellow dog trackpad notap" turned up this.

Try it. I believe that it just executes trackpad notap on boot, but it's just a guess.

  • No dice. I tried it and got writing /dev/adb: No such device or address. Thanks though. – rampion Apr 12 '11 at 17:47

I am not sure if "yellow DOg" linux but this is what I use in my Linux to turn off my pad on my lap top. its just a copy and paste of what I do to turn that dang thing off

# Turn off touch pad
# placed in ~/.xproflie also 
exec xinput set-prop 12 "Device Enabled" 0
exec synclient touchpadoff=1 
exec synclient VertEdgeScroll=0 
exec synclient TapButton1=0
exec synclient TapButton2=0
exec synclient TapButton3=0

Use synclient TouchpadOff=1 to disable and synclient TouchpadOff=0 to enable from the terminal. This will affect current session only. Run with sudo if permission is denied.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.