0

I'm trying to put together an Apache configuration for quickly getting IBM Cognos Business Intelligence Server up and running. But I got no idea of how to do it, could someone help me?

1

This setup was performed with IBM Cognos Business Intelligence Server 10.1.0 32-bit, running on Debian Wheezy stable for i686 on an VirtualBox virtual machine; so far I haven't been able to reproduce it on AMD64 or other distros. I am currently trying to reproduce it on KVM. It relies on the following assumptions:

  1. You are using the "default" approach of using Cognos's bundled middleware (Apache Tomcat as servlet container and Derby for the content store), starting everything from cogconfig.sh, i.e. you're not deploying to a separate Jave EE application server.
  2. You are running all the components on a single computer.
  3. You will do the required security setup later.
  4. You are running Debian Linux -- in other OSes, Apache will most likely have different paths for configuration files and commands.
  5. You have an user and group on your system both called cognos.
  6. Cognos's application files are installed on /usr/cognos/c101/.
  7. You're using the OpenJDK JRE. On Debian, if you have OpenJDK for Java 1.6 on a 32-bit system, this means JAVA_HOME=/usr/lib/jvm/java-6-openjdk-i386/jre.

First, start out by putting the following on your Apache configuration, httpd.conf or apache2.conf depending on your OS:

LoadModule cgi_module /usr/lib/apache2/modules/mod_cgi.so

<Directory "/usr/cognos/c101/webcontent/">
   Options None
   AllowOverride All
   Order allow,deny
   Allow from all
</Directory>

<Directory "/usr/cognos/c101/cgi-bin/">
   Options +ExecCGI
   AllowOverride Limit
   AddHandler cgi-script .cgi
</Directory>

ScriptAlias /webcontent/cgi-bin/ /usr/cognos/c101/cgi-bin/
Alias /webcontent/ /usr/cognos/c101/webcontent/

Next, put the following gateway URL on cogconfig.sh: http://<your hostname>:80/webcontent/cgi-bin/cognos.cgi

Finally, make sure Apache is running under the same user as Cognos and can read the program directories. I did this like this:

  1. Set export APACHE_RUN_USER=cognos and export APACHE_RUN_GROUP=cognos on the file where you put your Apache environment variables (on Debian Wheezy it's in /etc/apache2/envvars, on Red Hat Enterprise Linux it's /etc/sysconfig/httpd).
  2. As root, run chown -R cognos:cognos /usr/cognos.
  3. Run su - cognos and start cogconfig.sh. You might need to copy your xauth cookie as indicated here as well as your $DISPLAY environment variable in order to get the GUI to start.
  4. As cognos, start Cognos from Cognos Configuration.
  5. As root, start Apache.

Once everything is started, start Firefox (Cognos doesn't work with any other browser) and go to http://<your hostname>/webcontent/cgi-bin/cognos.cgi. You should be able to enter Cognos Connection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.