3

I was trying to setup the firewall settings, and probably did something wrong. I don't have internet now unless I stop iptables service

I tried flushing,and accepting everything

sudo iptables -F
sudo iptables -P OUTPUT ACCEPT
sudo iptables -P INPUT ACCEPT

But I still cannot access internet. if I stop the service,

sudo service iptables stop

then I can access inet. Starting again blocks it.

Can you point me where the problem lies?

(I'm running CentOS 6.4)

  • iptables -L what gives? – ludiegu Dec 10 '13 at 20:52
  • 2
    iptables has several other tables, try iptables -t nat -S, iptables -t mangle -S, iptables -t raw -S. – BatchyX Dec 10 '13 at 20:58
  • I played with the firewall settings as the other answer suggested, and now it works. I got something somewhere got changed, and now its good. – xcorat Dec 10 '13 at 21:46
8

The iptables command per default only shows entries of the filter table.

But there are also other tables:

enter image description here

There are probably some entries in the nat table. Add -t nat to your commands to look at them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.