2

I'm working on a relatively clean install of Wheezy - relatively as I installed it today and have been installing packages for quite some time. I previously had Ubuntu which played sounds, so it's not a hardware problem.

I have little information initially as I've tried all sorts of things found online, but can't remember what I did. So please, do ask me to include info in the comments.

The problem: Wheezy (or alsa or gstreamer or whatever handles the sound) doesn't see my sound card. It does see it as a piece of hardware, but it doesn't see it as a sound card. For example, I can see it when I run lspci -v (together with the Nvidia HDMI output). Here goes:

Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)

Subsystem: Giga-byte Technology Device a002
Flags: bus master, slow devsel, latency 32, IRQ 16
Memory at fe024000 (64-bit, non-prefetchable) [size=16K]
Capabilities: < access denied >
Kernel driver in use: snd_hda_intel

alsamixer displays a nice bar, but when I try to select the sound card (HDA ATI SB) it fails with cannot load mixer controls: Invalid argument.

During boot, alsa fails to start and displays a bunch of hw error invalid argument messages (or something similar, the text goes too fast to read).

Basic checks: I am in the audio group, nothing is muted, the speakers are plugged in & set to a reasonable volume. Before I did anything else I fiddled with the Sound settings (as I had previously done on Ubuntu) and the PulseAudio volume control, PulseAudio manager (which only sees Built-in Audio Analog Stereo and HDMI), and of course the gnome sound settings.

How do I make Alsa work with my sound card?

  • After booting, dmesg outputs the contents of the system log buffer. – CL. Dec 9 '13 at 7:57
  • Nope, sorry. Useful command but in my case I can't see the error messages. I rebooted since I posted this and I remember alsamixer is the one complaining about invalid parameters. @CL – rath Dec 9 '13 at 12:01
0

There can be more than one way to do this. But I recommend you to disable internal sound hardware of beaglebone black by adding optargs=capemgr.disable_partno=BB-BONELT-HDMI in the end of /boot/uEnv.txt file. And reboot your board with sound card connected. This will make your sound card as default hardware . So every sound process will select your sound card automatically.

  • 1
    It was a desktop PC, not a beaglebone. Anyway I've since upgraded and/or plugged my headphones to a different jack so the problem is near-unreproducible. Cheers – rath May 10 '16 at 10:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.