19

I'm following the Arch Beginner's Guide.

I have Arch running. Now I'm working on the post-installation instructions, one of the first parts of which is to unmute the speakers. This is where my problem is.

First, I installed alsamixer

pacman -S alsa-utils

Then this

amixer sset Master unmute

I get this error:

amixer: Unable to find simple control 'Master',0

I don't know how to proceed.

EDIT:

# cat/proc/asound/cards
0 [MID]: Hda-Intel - HDA Intel MID
         HDA Intel MID at 0xf7e14000 irq 63
1 [PCH]: Hda-Intel - HDA Intel PCH
         HDA Intel PCH at 0xf7e10000 irq 59 

# amixer -c1 sset Master unmute
Simple mixer control 'Master',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 87
Mono: Playback 60 [69%] [-20.25dB] [on]

# speaker-test -c 2

speaker-test 1.9.27.2

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2, No such file or directory
  • 1
    What's the output of cat /proc/asound/cards? – Elias Probst Dec 8 '13 at 20:29
  • @EliasProbst I've updated the question with that info. – Korgan Rivera Dec 8 '13 at 20:37
  • 1
    Ok, it looks like your MIDI-Controller is Card#0, so try amixer -c1 sset Master unmute instead. – Elias Probst Dec 8 '13 at 20:44
  • @EliasProbst Ok I tried that. I updated the question with the output. – Korgan Rivera Dec 8 '13 at 20:56
  • 1
    @CL."speaker-test -c 2 -D plughw:1" works, and it also works with "-c 2". – Korgan Rivera Dec 8 '13 at 21:13
15

When setting up a new Arch install I usually do the following:

pacman -S alsa-utils

Then fire up alsamixer with

alsamixer

Go to 'Master' then press M and then keep hitting the up key to bring the sound levels up. I do that for any other inputs I want like pcm etc.

Then do

speaker-test -c2 

with the number being how many channels you want to test. You should hear static from each channel in turn.

11

I recommend asoundconf, which will take care of generating a proper .asoundrc .

  1. List the available sound cards:

    asoundconf list

  2. Set the default one:

    asoundconf set-default-card PARAMETER

  3. Unmute it if necessary through either alsamixer(ncurses) or amixer (cli)

  • This saved me much time :D – hso Sep 26 '15 at 1:11
  • This is without a doubt the easiest way to get that overly complex system to work. – Simon Shine Oct 26 '16 at 19:36
2

If you do not want to use the HDMI output as the default output device, and if are using PulseAudio, select the "PCH" card as the default card in PulseAudio.

For pure ALSA applications, add the following to /etc/asound.conf or your ~/.asoundrc:

defaults.ctl.card PCH
defaults.pcm.card PCH

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.