2

I'm running Debian testing and I have a script that sets the volume of speakers on startup that looks like this:

amixer -c 0 set Surround  50% > /dev/null &
amixer -c 0 set Center   100% > /dev/null &
amixer -c 0 set Front     80% > /dev/null &
amixer -c 0 set LFE       50% > /dev/null &
amixer -c 0 set Side      80% > /dev/null &

The problem I'm having is that this configuration is reset to the default every few minutes so I have to continuously run the script to fix my configuration.

I think it happens most often when I'm watching something that is using flash or a browser. I can successfully watch a movie with VLC without this happening.

Anyone have any clue as to what the problem is?

  • 1
    You probably should report this as a bug to the Debian maintainers. What's to say it will be fixed by the time Jessie is released if you don't? Running testing or sid means you're taking part in the social contract of making Debian as stable as it is. – a CVn Dec 11 '13 at 13:46
0

The problem could be connected with pulseaudio.

See http://blog.waan.name/pulseaudio-setting-volume-from-command-line/ for a script which allows you to change the volume.

  • I agree with pulseaudio as responsable. Look at message #27 on this thread bugs.debian.org/cgi-bin/bugreport.cgi?bug=556971 Look this lines: Severity: normal simply in default.pa commenting the lines load-module module-device-restore load-module module-stream-restore load-module module-card-restore solves the issue, too. – vfbsilva Dec 11 '13 at 19:57
  • Or from message #47 installing alsa-utils will do it too. – jthill Dec 12 '13 at 20:41
  • You may be right that it is connected to pulseaudio, but the problem I am having is not the same as the one listed in any of the links. I'm having the problem of the sound settings resetting every few minutes. Not only at reboot. I tried all of the fixes listed and none of them worked. – nulvinge Dec 16 '13 at 10:56
  • @nulvinge can you post your and asoundrc? Can it be related to priority of the process as stated here? wiki.debian.org/en/PulseAudio#Wheezing_and_audio_interruptions – vfbsilva Dec 17 '13 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.