3

I'm trying to install some packages form yaourt.

For example :

yaourt compiz

But it gets me following error:

[hamed@localhost ~]$ yaourt compiz
curl error: SSL connect error

Please tell me what's wrong with yaourt?

  • 3
    Apparently, your government doesn't want you accessing the AUR. – jasonwryan Dec 6 '13 at 18:52
  • I don't think so. Because I can open this link aur.archlinux.org and download packages. – Hamed Kamrava Dec 6 '13 at 18:56
  • 1
    Another Iranian user has complained about this in the past. Either install from AUR manually or, if you want to keep using yaourt, use a proxy. – jasonwryan Dec 6 '13 at 19:07
1

This problem apparently occurs for Iranian people.

The Solution :

You have to replace yaourt-ssl3 and package-query-ssl3 instead yaourt and package-query.

Firstly you need to uninstall current yaourt and package-query by following command :

sudo pacman -Rsc package-query

And then install ssl3 :

curl -O3 https://aur.archlinux.org/packages/pa/package-query-ssl3/package-query-ssl3.tar.gz
tar -xf package-query-ssl3.tar.gz
cd package-query-ssl3
makepkg -cis
cd ..
curl -O3 https://aur.archlinux.org/packages/ya/yaourt-ssl3/yaourt-ssl3.tar.gz
tar -xf yaourt-ssl3.tar.gz
cd yaourt-ssl3
makepkg -cis

That's it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.